How to download LXC version of OpenWRT and run it on Proxmox

The previous guides are nice, but actually there are just a few steps needed to have a running LXC-openWrt Host.
A bit overspecific.

Download from https://fra1lxdmirror01.do.letsbuildthe.cloud/images/openwrt/23.05/amd64/default/

copy your file in the correct folder.
scp rootfs.tar.xz root@pve2:/var/lib/vz/template/cache/openwrt_23.05_amd64_rootfs.tar.xz

create the container
root@pve2:~# pct create 155 /var/lib/vz/template/cache/openwrt_23.05_amd64_rootfs.tar.xz --arch amd64 --hostname vwrt.homelab.lan --rootfs pve-vm:2 --memory 1024 --cores 1 --description vwrt0-router --ostype unmanaged --unprivileged 1 --features nesting=1

So before we boot up that host, let's add some NIC's
1734127431345.png


eth0 or eth0.2 is usually the WAN Port.
eth1 or eth0.1 is usually the LAN/Bridge Port.

so in my case it's veth0(WAN) and veth1(LAN)

change your network settings
root@vwrt:/# vi /etc/config/network
so it looks like:
root@vwrt:/# cat /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'wan'
option ifname 'veth0'
option proto 'dhcp'

config interface 'wan6'
option ifname 'veth0'
option proto 'dhcpv6'

config interface 'lan'
option proto 'static'
option device 'veth1'
option netmask '255.255.255.nn''
option gateway '192.168.nn.nn'
option ipaddr '192.168.nn.nn'

restart your network service and check your ifconfig
root@vwrt:/# /etc/init.d/network restart
root@vwrt:/#
root@vwrt:/# ifconfig

veth1 should be online already.

give your host a ping to check if it is reachable

navigate to https://192.168.nn.nn

1734126764193.png

1734126913767.png


whishes for Christmas
  • I'd like to see in Proxmox --ostype openwrt
  • and to have openwrt as lxc templates already available for download
 
Last edited:
other network settings also possible

like if you have a single NIC and you can do 802.1q VLAN's on your internal Switch.

1734129012400.png

root@vwrt:/# vi /etc/config/network
config interface 'wan6'
option proto 'dhcpv6'
option device 'veth0.2'
option auto '0'
option reqaddress 'try'
option reqprefix 'auto'

config interface 'lan'
option proto 'static'
option device 'veth0.1'
option netmask '255.255.255.nn'
option gateway '192.168.nn.nn'
option ipaddr '192.168.nn.nn'

config device
option type '8021q'
option ifname 'veth0'
option vid '2'
option name 'veth0.2'

config device
option type '8021q'
option ifname 'veth0'
option vid '1'
option name 'veth0.1'

In the GUI

1734128542311.png


1734128666837.png

1734128811891.png


1734128923101.png
 
Last edited:
I prefer to paste a chunk of text in the proxmox shell and have it work immediately.
In particular, not have to first create,chown,;./run_myscript.sh

I spent too much time trying to do stuff in GUI, I need it working immediately and we all the needed application pre-installed and pre-configured, keys uploaded etc..
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!