High CPU load for Windows 10 Guests when idle

sdet00

New Member
Nov 18, 2017
21
1
3
Perhaps a silly question, but would it be advisable to simply disable HPET in the BIOS of the host until this is fixed?
 

sdet00

New Member
Nov 18, 2017
21
1
3
Update - out of curiosity it looks like you can't disable HPET on modern HP business grade hardware, so there's that. Will the workarounds in this thread potentially interfere with fixes in the future? Also, has anyone tried Windows 10 1809 yet?
 

pfoo

New Member
Jan 21, 2012
20
0
1
On a HP DL120G7 E3-1220 running proxmox 5.2-9, my idling 2 core windows 10 Pro 1803 VM gets :
- ~15% cpu usage with OS type Windows 10/2016
- ~3% cpu usage with OS type Other
- ~1-1.5% cpu usage with OS type Windows 10/2016 and no-hpet commented out (post #9)
- ~0.8-1% cpu usage with OS type Windows 10/2016 and hv_synic and hv_stimer flags (post #11)

No drawback as far as I can tell.

Is there any reason why proxmox has not yet implemented the patch from post #11 ?
 

loomes

Member
May 22, 2018
58
12
8
39
@pfoo

It is implemented and would active when the qemu 3 update package goes live on the repository.
 

delebru

New Member
Jul 10, 2018
23
1
3
31
@loomes

can you try another thing:

keep no-hpet, and change this (same QemuServer.pm file)

if ($winversion >= 7) {
push @$cpuFlags , 'hv_relaxed';
}

to
if ($winversion >= 7) {
push @$cpuFlags , 'hv_relaxed';
push @$cpuFlags , 'hv_synic';
push @$cpuFlags , 'hv_stimer';

}

then restart pvedaemon and stop/start vm .
This worked for me too! Win10 VM on idle was averaging 14% CPU, dropped down to 2%. Thanks!
 
  • Like
Reactions: AlexLup

Marco Trevisan

New Member
Nov 6, 2018
7
6
3
45
HI all,
just reporting a similar case with Windows 10 guests that I solved recently.
The win10 guests suddenly started eating 100% of one of the assigned cores as soon as the user closed the Remote Desktop *window*, and stayed in that condition until the next RDP logon.
If instead the user "disconnects" from the Windows session, the RDP client will close and the guest will consume no extra CPU.

Assuming you're using the Remote Desktop client, you may double check on how you logoff from your RDP session. If you simply click the "X" button on the RDP window, chances are you are triggering that weird behavior.

My 2 cents.
Regards,
Marco
 
Mar 28, 2018
58
1
8
49
Hi all,

we too had the problem with a Win 10 Installation going 100% CPU after a while the user logged out from RDP. We solved by updating the virtio drivers from the virtio-win-0.1.171.iso. Before we had the drivers installed from virtio-win-0.1.141.iso.

Regards,
Thomas
 

Marco Trevisan

New Member
Nov 6, 2018
7
6
3
45
Hi Thomas,
thanks for the info, I will double check that too. I upgraded to virtio-win-0.1.172.iso (Fedora releases site) from the former 0.1.160, but things didn't change. My procedure was to upgrade all the drivers from the "Device management" Win10 panel, maybe I missed one of the VirtIO drivers.

Regards,
Marco
 
Jun 1, 2019
135
21
18
33
Moscow, Russia
Hello,

Managed to solve the very same problem. It's an issue related to graphics driver after the 1903 update and it's a known issue.
The issue manifests after initiating an RDP session, then exiting the session without the logout of the user.

To replicate the issue:
  1. Create a Windows 10 1903 VM (CPU should be at ~0-1% idle)
  2. Access the VM via RDP connection
  3. Close the connection (CPU should be at ~20-30% idle, depending on the number of sessions and CPU settings)
Details: https://answers.microsoft.com/en-us/windows/forum/all/dwmexe-high-cpu-one-core-on-target-system-after/dbce0938-60c5-4051-81ef-468e51d743ab

The solution

As a workaround on all of my affected machines I have used Group Policy Editor to set:

Code:
Local Computer Policy
⌞ Computer Configuration
 ⌞ Administrative Templates
  ⌞ Windows Components
   ⌞ Remote Desktop Service
    ⌞ Remote Desktop Session Host
     ⌞ Remote Session Environment
      ⌞ Use WDDM graphics display driver for Remote Desktop Connections
to DISABLED

This forces RDP to use the old (and now deprecated XDDM drivers).

After the reboot, the idle should go to the normal 0-1%.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!