[SOLVED] help to enable iommu


New Member
Jun 8, 2023
I have proxmox running on Asus Sabertooth x79 mobo with single Xeon E5-2697. I'm trying to setup Plex VM with Nvidia GPU in passthrough mode. For whatever reason appears IOMMU is not enabled. I triple checked the bios settings and everything related to virtualization of CPU is enabled. I updated to the latest bios for this particular motherboard is 4801. Here is the output of the shell:
root@pve:~# dmesg | grep -i iommu
[ 0.365685] DMAR-IR: IOAPIC id 0 under DRHD base 0xfbffc000 IOMMU 0
[ 0.365688] DMAR-IR: IOAPIC id 2 under DRHD base 0xfbffc000 IOMMU 0
[ 0.739840] iommu: Default domain type: Translated
[ 0.739840] iommu: DMA domain TLB invalidation policy: lazy mode

I followed the instructions from here: https://pve.proxmox.com/wiki/PCI_Passthrough

But when I try to add PCI device to VM I see the message that says that IOMMU is not enabled.
Please help.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!