[SOLVED] [GUI] Node list empty during VM creation / migration

Cecile28

New Member
Apr 6, 2018
2
0
1
23
Hello,
My node list is empty when I want to create / migrate a VM or container.
This is only a GUI issue, CLI works fine.


The cluster is healthy too. Nothing wierd in logs.
I also tried to restart the concerned services without improvement...
Code:
systemctl restart pvestatd
systemctl restart pvedaemon
systemctl restart pveproxy
Any idea on a how to fix ?
Thanks a lot


Some useful data...
Code:
root@px5:/var/log# pvecm status
Quorum information
------------------
Date:             Fri Apr  6 12:59:51 2018
Quorum provider:  corosync_votequorum
Nodes:            6
Node ID:          0x00000002
Ring ID:          6/3596
Quorate:          Yes

Votequorum information
----------------------
Expected votes:   7
Highest expected: 7
Total votes:      6
Quorum:           4 
Flags:            Quorate

Membership information
----------------------
    Nodeid      Votes Name
0x00000006          1 10.0.10.120
0x00000001          1 10.0.10.130
0x00000002          1 10.0.10.150 (local)
0x00000007          1 10.0.10.160
0x00000004          1 10.0.10.210
0x00000005          1 10.0.10.220
Code:
root@px5:/var/log# pveversion -v
proxmox-ve: 5.1-42 (running kernel: 4.13.16-1-pve)
pve-manager: 5.1-46 (running version: 5.1-46/ae8241d4)
pve-kernel-4.13: 5.1-43
pve-kernel-4.13.16-1-pve: 4.13.16-45
pve-kernel-4.10.17-2-pve: 4.10.17-20
ceph: 12.2.4-pve1
corosync: 2.4.2-pve3
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.0-8
libpve-common-perl: 5.0-28
libpve-guest-common-perl: 2.0-14
libpve-http-server-perl: 2.0-8
libpve-storage-perl: 5.0-17
libqb0: 1.0.1-1
lvm2: 2.02.168-pve6
lxc-pve: 2.1.1-3
lxcfs: 2.0.8-2
novnc-pve: 0.6-4
openvswitch-switch: 2.7.0-2
proxmox-widget-toolkit: 1.0-11
pve-cluster: 5.0-20
pve-container: 2.0-19
pve-docs: 5.1-16
pve-firewall: 3.0-5
pve-firmware: 2.0-4
pve-ha-manager: 2.0-5
pve-i18n: 1.0-4
pve-libspice-server1: 0.12.8-3
pve-qemu-kvm: 2.9.1-9
pve-xtermjs: 1.0-2
qemu-server: 5.0-22
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.6-pve1~bpo9
 

Cecile28

New Member
Apr 6, 2018
2
0
1
23
I have an error, but no clue idea how to fix...
Dedibox is one of my node name (currently down)

Code:
root@px5:~# pvesh get /nodes
unable to read '/etc/pve/nodes/dedibox/pve-ssl.pem' - No such file or directory
EDIT :
I deleted the involved node dedibox, but the same error appear on one of my active datastore :
Code:
root@px5:/etc/pve/nodes# pvesh get /nodes
unable to read '/etc/pve/nodes/datastore2/pve-ssl.pem' - No such file or directory
I still have no clue idea how to proceed.

SOLUTION :
Fixed with regenerating the key on the involved (datastore2) node.
Code:
pvecm updatecerts -f
Thank you for the support :)
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!