GPU passthru blank screen

BICEPS

Member
Aug 20, 2019
9
0
6
33
Hey everyone,

Before I start, here's what I'm working with. If anyone knows any alternate formatting to {code} that would be pretty cool :p
Code:
i7 6700
GTX1060
32GB RAM
850EVO as only SSD

I have been following Nick Sherlock's blog post on getting a Mojave VM and I eventually got installed. Only problem is getting the GPU to work inside of the VM. Turning my PC on, proxmox goes through it's usual boot sequence then once I fire up the VM , all I get is a black, blank output on my monitor. After a couple of seconds, my monitor says it's going to enter Power Saver Mode, implying there is no signal coming from the gpu. So I know I did something at least.

this is my lspci output
Code:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1)
        Subsystem: Gigabyte Technology Co., Ltd GP106 [GeForce GTX 1060 6GB] [1458:371a]
        Kernel driver in use: vfio-pci
        Kernel modules: nvidiafb, nouveau
01:00.1 Audio device [0403]: NVIDIA Corporation GP106 High Definition Audio Controller [10de:10f1] (rev a1)
        Subsystem: Gigabyte Technology Co., Ltd GP106 High Definition Audio Controller [1458:371a]
        Kernel driver in use: vfio-pci
        Kernel modules: snd_hda_intel
I have also verified that my iommu groups are all good with my graphics card, audio and pcie bridge all grouped up.

I have followed the docs step by step and enabled intel iommu, added the kernel modules,
blacklisted the nvidia drivers
Code:
blacklist nvidiafb
blacklist snd_hda_intel
blacklist radeon
blacklist nouveau
blacklist amdgpu
blacklist nvidia
modified my vfio.conf
Code:
options vfio-pci ids=10de:1c03,10de:10f1 disable_vga=1
and passed it through to the VM with these arguments
Code:
hostpci0: 01:00.0,pcie=1,rombar=0,romfile=1060tpu1.rom,x-vga=1
The rom file is not my own dump because mine did not fit the criteria of having a type 3, just a plain 0. However, I made sure it is the same model as mine. Sloppy job I know. Even without the romfile, I come across the same problem anyways.

I've been on this for 6 hours now looking threads all over the proxmox forums but I still can't find what I'm doing wrong. If I'm missing any information, please just ask away. Thanks in advance to everybody! I am losing my mind trying to get this to work!
 
Try this

Code:
qm set ID -args '-machine type=q35,kernel_irqchip=on'

Replace ID with VM ID
 
And did you try without rom file and rombar setting? 1060 should be UEFI compatible.
 
Yes, I have tried with and without the romfile and rombar setting. I thought that the 1060 is uefi compatible too but on my own vbios dump, mine did not. However, checking the dumps on TPU, those did. Still having the same problem of having no graphic output whatsoever on my monitor. I shouldn't be having this much problem should I?

Also, do my bios settings matter? I saw some threads that talked about the GPU priority settings but I couldn't seem to understand it.
 
Please post full config for VM. And what is the Primary graphics card? If intel HD is not being used as primary it could conflict the passthrough.
 
Sure, here's my vm conf
Code:
args: -device isa-applesmc,osk="thisisaplaceholdersoignorethis" -smbios type=2 -cpu Penryn,kvm=on,vendor=GenuineIntel,+invtsc,vmware-cpuid-freq=on,+pcid,+ssse3,+sse4.2,+popcnt,+avx,+aes,+xsave,+xsaveopt,check -device usb-kbd,bus=ehci.0,port=2,kernel_irqchip=on
balloon: 0
bios: ovmf
boot: cdn
bootdisk: sata0
cores: 4
cpu: Penryn
efidisk0: local-lvm:vm-100-disk-1,size=128K
hostpci0: 01:00,pcie=1,romfile=1060.rom,x-vga=1
machine: q35
memory: 30000
name: iMac
net0: vmxnet3=2A:BF:F0:5C:38:17,bridge=vmbr0,firewall=1
numa: 0
onboot: 1
ostype: other
sata0: local-lvm:vm-100-disk-0,size=215G
smbios1: uuid=6a37c1f8-1347-4907-b7cd-d5157569d2b4
sockets: 1
vga: none
vmgenid: c84e29b9-a6d3-449a-aaf1-7d5e1238dd28

the 1060.rom romfile is my own gpu's dump so no worries there.
 
You don't really need it. Qemu is more then capable to boot if it is UEFI compatible already. Did you check IGPU setting in bios? it needs to be set as Primary.
 
Yes, I have already set it to prioritize CPU Graphics but I am having the same problem with the blank no signal output screen on my monitor still.
 
did you try to passthrough without uefi since your card does not seem to support it ?
 
did you try to passthrough without uefi since your card does not seem to support it ?
I don't think I have as I have no clue how to do so. Skimming through the docs don't seem to offer that option. How do I go about doing that?
 
I don't think I have as I have no clue how to do so. Skimming through the docs don't seem to offer that option. How do I go about doing that?
simply change the bios from 'ovmf' to 'seabios' in the gui
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!