Failed to run lxc.prehook.start


New Member
Aug 9, 2021
***LVM was full. I missed that.

I am creating a new Ubuntu container, doing a release upgrade on it and then rebooting.
After I reboot the container, it fails to start and gives the error in the title.
I have deleted the container and tried again. I tried privielged and unprivileged. Both produce the same results.

2 other forum posts here with the same issue saty its a disk issue.
None of my disks are full and I am not storing to a remote disk.

root@proxmox:~# pveversion -v
proxmox-ve: 6.4-1 (running kernel: 5.4.128-1-pve)
pve-manager: 6.4-13 (running version: 6.4-13/9f411e79)
pve-kernel-5.4: 6.4-5
pve-kernel-helper: 6.4-5
pve-kernel-5.3: 6.1-6
pve-kernel-5.4.128-1-pve: 5.4.128-1
pve-kernel-5.4.124-1-pve: 5.4.124-2
pve-kernel-5.4.106-1-pve: 5.4.106-1
pve-kernel-5.4.78-2-pve: 5.4.78-2
pve-kernel-5.4.65-1-pve: 5.4.65-1
pve-kernel-5.4.44-2-pve: 5.4.44-2
pve-kernel-4.15: 5.4-11
pve-kernel-5.3.18-3-pve: 5.3.18-3
pve-kernel-5.3.13-1-pve: 5.3.13-1
pve-kernel-5.3.10-1-pve: 5.3.10-1
pve-kernel-4.15.18-23-pve: 4.15.18-51
pve-kernel-4.15.18-15-pve: 4.15.18-40
pve-kernel-4.15.18-12-pve: 4.15.18-36
pve-kernel-4.15.18-8-pve: 4.15.18-28
pve-kernel-4.15.18-1-pve: 4.15.18-19
pve-kernel-4.15.17-1-pve: 4.15.17-9
pve-kernel-4.10.17-2-pve: 4.10.17-20
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.1.2-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: residual config
ifupdown2: 3.0.0-1+pve4~bpo10
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.20-pve1
libproxmox-acme-perl: 1.1.0
libproxmox-backup-qemu0: 1.1.0-1
libpve-access-control: 6.4-3
libpve-apiclient-perl: 3.1-3
libpve-common-perl: 6.4-3
libpve-guest-common-perl: 3.1-5
libpve-http-server-perl: 3.2-3
libpve-storage-perl: 6.4-1
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.6-2
lxcfs: 4.0.6-pve1
novnc-pve: 1.1.0-1
proxmox-backup-client: 1.1.12-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.6-1
pve-cluster: 6.4-1
pve-container: 3.3-6
pve-docs: 6.4-2
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-4
pve-firmware: 3.2-4
pve-ha-manager: 3.1-1
pve-i18n: 2.3-1
pve-qemu-kvm: 5.2.0-6
pve-xtermjs: 4.7.0-3
qemu-server: 6.4-2
smartmontools: 7.2-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 0.8.5-pve1

root@proxmox:~# pct start 141
run_buffer: 314 Script exited with status 255
lxc_init: 798 Failed to run lxc.hook.pre-start for container "141"
__lxc_start: 1945 Failed to initialize container "141"
startup for container '141' failed

root@proxmox:~# lsblk -f
NAME                         FSTYPE            LABEL     UUID                                   FSAVAIL FSUSE% MOUNTPOINT
loop0                        ext4                        6ef21c51-deb8-4170-9f7f-5f2191541793
loop1                        ext4                        99740460-48d8-45c1-a6fb-554b86169a3c
loop2                        ext4                        f0203e01-3741-40a5-8928-9b8e5d26122a
loop3                        ext4                        e4b633cd-107e-4b1c-9c3c-788b3927fee9
loop4                        ext4                        9a3afe65-8743-4b28-8778-ea36e024c074
loop5                        ext4                        a7657e23-d980-4060-a597-39d1f3c94c7a
loop6                        ext4                        68674a4f-c039-42aa-a8cd-a86bafd0b627
loop7                        ext4                        2d2777cc-9717-4120-8420-60f655a29ae8
loop8                        ext4                        e70719bf-0c2b-4c05-b812-59cf060ee976
loop9                        ext4                        274642bd-52c0-44cf-a4b2-cbdfec9e244e
loop10                       ext4                        9579e1cd-4883-4bef-a401-c2bc64eedbc7
loop11                       ext4                        b0de82b0-f368-4809-9d9a-ae601fdde050
loop12                       ext4                        914adc02-b9dd-43c9-9e0a-3f022e500586
loop13                       ext4                        acf5ee6e-f6e4-43d2-bc17-fb161748c1c1
loop14                       ext4                        863db701-38a1-43d7-9bf6-410d2ebc623f
|-sda2                       vfat                        30E1-7A17
|-sda3                       LVM2_member                 yMtehV-jLkn-EtnX-BhpS-PbpO-xFon-U5cbNo
| |-pve-swap                 swap                        1367249a-6666-4137-8bb7-463332bc5166                  [SWAP]
| |-pve-root                 ext4                        5445f01e-4d5c-45f9-82d8-4939a5926c69     68.1G    22% /
| |-pve-data_tmeta
| | `-pve-data-tpool
| |   |-pve-data
| |   `-pve-vm--115--disk--0
| `-pve-data_tdata
|   `-pve-data-tpool
|     |-pve-data
|     `-pve-vm--115--disk--0
`-sdb1                       ext4                        f793605f-89cb-42bf-89aa-3157c04183d4    320.8G    79% /mnt/RAID10
`-sdc1                       ext4                        4490b1d7-6b11-4c83-b1a8-ae982d91393d    508.4G    39% /mnt/RAID5
sdd                          linux_raid_member proxmox:0 7c222e23-b0dd-0094-0acb-63d4912cf103
`-md0                        ext4                        61f20988-afcf-4e2e-acc9-c1d978b26bbc     23.4T    30% /mnt/MediaRAID
sde                          linux_raid_member proxmox:0 7c222e23-b0dd-0094-0acb-63d4912cf103
`-md0                        ext4                        61f20988-afcf-4e2e-acc9-c1d978b26bbc     23.4T    30% /mnt/MediaRAID
sdf                          linux_raid_member proxmox:0 7c222e23-b0dd-0094-0acb-63d4912cf103
`-md0                        ext4                        61f20988-afcf-4e2e-acc9-c1d978b26bbc     23.4T    30% /mnt/MediaRAID
sdg                          linux_raid_member proxmox:0 7c222e23-b0dd-0094-0acb-63d4912cf103
`-md0                        ext4                        61f20988-afcf-4e2e-acc9-c1d978b26bbc     23.4T    30% /mnt/MediaRAID
sr0                          udf               LEOLO     431daa7a5f5f5f4d

root@proxmox:~# lvs -a
  LV              VG  Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  data            pve twi-aotz-- 345.00g             30.17  24.42
  [data_tdata]    pve Twi-ao---- 345.00g
  [data_tmeta]    pve ewi-ao----  88.00m
  [lvol0_pmspare] pve ewi-------  88.00m
  root            pve -wi-ao----  96.00g
  swap            pve -wi-ao----   8.00g
  vm-115-disk-0   pve Vwi-aotz-- 106.00g data        98.20

root@proxmox:~# vgs -a
  VG  #PV #LV #SN Attr   VSize    VFree
  pve   1   4   0 wz--n- <465.00g 15.82g

root@proxmox:~# cat /etc/pve/lxc/141.conf
arch: amd64
cores: 2
hostname: Piped
memory: 4096
net0: name=eth0,bridge=vmbr2,hwaddr=62:e0:d9:44:00:c1,ip=dhcp,tag=74,type=veth
ostype: ubuntu
rootfs: BigRAID:141/vm-141-disk-0.raw,size=32G
swap: 0
unprivileged: 1
Last edited:
***LVM was full. I missed that.
is your issue gone then? if that's the case please mark the thread as [SOLVED]

otherwise you could post the output from pct start 141 --debug here and we'll take a look :)


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!