External VNC Client

SergeantFTC

New Member
Jul 5, 2011
23
0
1
I believe that the roadmap says that we are supposed to be able to use an external VNC client now. How do I do this?
 

coffe

Member
Apr 16, 2009
153
0
16
nc -l -p 5901 -c "qm vncproxy MachineID PASSWORD" dont know is that is working in 2.0. but that is what i use in 1.9
 

vadq

New Member
Oct 25, 2011
3
0
1
nc -l -p 5901 -c "qm vncproxy MachineID PASSWORD" dont know is that is working in 2.0. but that is what i use in 1.9
not working, the qm vncproxy in 2.0 is "qm vncproxy MachineID" but not "qm vncproxy MachineID PASSWORD".

When i tried

nc -l -p 5901 -c "qm vncproxy MachineID"

error from vnc client

"No matching security types"

;-(
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,690
435
83
your VNC client supports SSL?
 

bread-baker

Member
Mar 6, 2010
432
0
16
Does anyone have a suggestion for a Debian Squeeze client which supports 'client which support TLS vencrypt plain auth' ?


I have been testing remmina and so far have not got it working yet. googled and it seems to support tls..
 

bread-baker

Member
Mar 6, 2010
432
0
16
this is in inetd.conf:
Code:
29006 stream tcp nowait root /usr/sbin/qm qm vncproxy 100 secretpw
the qm is running :
Code:
root      708707       1  3 Oct25 ?        00:35:12 /usr/bin/kvm -id 100 -chardev socket,id=monitor,path=/var/run/qemu-server/100.mon,server,nowait -mon chardev=monitor,mode=readline -vnc unix:/var/run/qemu-server/100.vnc,x509,password -pidfile /var/run/qemu-server/100.pid -daemonize -readconfig /usr/share/qemu-server/pve-usb.cfg -device usb-tablet,bus=ehci.0,port=6 -name pro4-kvm -smp sockets=2,cores=2 -nodefaults -boot menu=on,order=c -vga cirrus -tdf -k en-us -drive if=none,id=drive-ide2,media=cdrom,aio=native -device ide-drive,bus=ide.1,unit=0,drive=drive-ide2,id=device-ide2 -device lsi,id=scsi0,bus=pci.0,addr=0x5 -drive file=/dev/drbdvg/vm-100-disk-1,if=none,id=drive-scsi0,aio=native,boot=on -device scsi-disk,bus=scsi0.0,scsi-id=0,drive=drive-scsi0,id=device-scsi0 -m 1024 -netdev type=tap,id=net0,ifname=tap100i0,script=/var/lib/qemu-server/pve-bridge -device rtl8139,romfile=,mac=1A:91:42:AD:73:29,netdev=net0,bus=pci.0,addr=0x12 -cpuunits 1000
for user name, I tried root@pam, root, and the normal empty. attached is a pic of the error message from a failled attempt to connect, and the configuration :
vnc-1.pngvnc-2.png


on this system, I had to install openbsd-inetd , maybe there is another package needed?

I do have vnc connections working with our proxmox 1.9 system.

when I get more time to work on this, I'll google that error msg.
 
Last edited:

bread-baker

Member
Mar 6, 2010
432
0
16
could you give an example of what to put in the server line of 'vncviewer'

for instance for root@pam , how do I put with:
10.100.100.158:29006
edit:

ok I figured it out, I had this in inetd.conf on prox host:

29006 stream tcp nowait root /usr/sbin/qm qm vncproxy 3001 # password


removed the comment so to have:
29006 stream tcp nowait root /usr/sbin/qm qm vncproxy 3001

then vncviewer worked.

testing the connection using telnet with ' telnet fbc158 29006 ' made testing the connection easy.
 
Last edited:

udo

Well-Known Member
Apr 22, 2009
5,864
161
63
Ahrensburg; Germany
at last i found it, you can use for win or linux

tigervnc from sourceforge

username must be "root@pam"
Hi,
tigervnc work well (short test),
but know anyone how to add an machine to another user than root?
The "dirty" way in pve1.x to use an second user with uid 0 don't work:
Code:
Dec  7 11:09:43 proxmox3 pvedaemon[100870]: authentication failure; rhost= user=spell@pam msg=no permission (/vms/310, VM.Console)
Udo
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!