[SOLVED] Error: mount: only root can use "--types" option (effective UID is 100000)

Zavod

New Member
Jan 8, 2021
3
0
1
37
Fresh install of Proxmox 6.3-3 on Debian 10 (4.15.18-1-pve).

Trying to make NFS shared folder for containers:

Allow NFS in apparmor profile: /etc/apparmor.d/lxc/lxc-default-cgns
Code:
mount fstype=rpc_pipefs,
mount fstype=nfs,
mount options=(rw, bind),
restart APPARMOR,
setup /etc/exports with /mnt/shared_folder 10.5.0.100(ro,sync,no_subtree_check)

LXC container config (Debian10 template):

/etc/pve/lxc/100.conf

Code:
arch: amd64
cores: 1
hostname: DebianTest
memory: 512
nameserver: ****
net0: name=eth0,bridge=vmbr0,firewall=1,gw=10.5.0.1,hwaddr=B6:FA:80:6C:4D:3D,ip=10.5.0.100/24,type=veth
ostype: debian
rootfs: local:100/vm-100-disk-0.raw,size=10G
searchdomain: ****
swap: 512
unprivileged: 0
unused0: A02:100/vm-100-disk-0.raw

But then i trying to mount shared folder inside container, got error:

root@DebianTest:/# mount -t nfs 10.5.0.1:/mnt/shared_folder/ /mnt
mount: only root can use "--types" option (effective UID is 100000)


No additiobal errors at syslog on NFS server. Trying with Ubuntu 18 template with same result.

On previous version of proxmox this setup works well, any ideas how to solve it ?
 
Last edited:

Zavod

New Member
Jan 8, 2021
3
0
1
37
I do not resolve this problem, so i found another way to mount shared folder from proxmox hypervisor inside container, via mount bind:
Code:
pct set 100 -mp0 /mnt/hypervisor_shared_folder/,mp=/mnt/,ro=1

This solved my goal to get a readonly shared folder for containers.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!