[SOLVED] dynamic resolution not working on windows

yusisushi

New Member
Feb 12, 2024
10
1
1
Hi, I found a number of threads about this but no suggested solution seems to work for me.

I installed the spice-guest-tools and all windows 11 updates but the resolution of the vm does not automatically adjust its resolution when I change the window size.

I also tried changing the biostype from OVMF (UEFI) to SeaBIOS as this was suggested in another thread, this made Windows refuse to boot or reinstall.

I also notice clipboard sharing between host and guest is not working, however the spice service is installed and runnig;
1708204659257.png

Below is a view of the 'Hardware' tab of this vm
1708204489705.png


Dynamic resolution based on window size does work for any linux vm I have. And it seems I have the same issue with Windows 10 guests, even after installing the spice and qemu guest tools.

In below image you can see the display adapter and display show as QEMU annd virtuo GPU. I don't get why the resolution doesn't automatically change
View attachment 63329
 
Last edited:
For anyone wondering, I eventually fixed it after reinstalling the virtuo-win-0.1.240 drivers for the tenth time. As well as changing the display to "Spice (qxl)"
 
  • Like
Reactions: Audieux

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!