DVD-ROM Issue in Win 10 VM

Jan 2, 2019
1
0
6
47
Hi,

I am brand new to ProxMox, and wanted to request some help in configuring a Win10 VM I am setting up.

The setup of Win10 OS in the VM went smoothly, but the DVD-Rom drive (ASUS Blue-ray) is not working.

There is a driver installed in the guest system: QEMU DVD-ROM ATA Device. Windows claims that device is working properly when I examine properties in Device Manager. Windows appears to mount the drive, and I can sometimes get a directory of the disk in File Explorer. However, I rarely can read or copy a file from the disk. The read does work, but rarely. The OS appears to hang when I attempt to access the DVD drive but I can recover with Task Manager. The drive is just unusable and I haven't been able to get it working reliably. If I try to change disks, the drive usually cannot read the new disk, and I just am shown in file explorer the same files from the last disk that I removed.

Here are the contents of my VM configuration file:
args: -device intel-hda,id=sound5,bus=pci.0,addr=0x18 -device hda-micro,id=sound5-codec0,bus=sound5.0,cad=0 -device hda-duplex,id=sound5-codec1,bus=sound5.0,cad=1
bootdisk: virtio0
cores: 4
ide2: cdrom,media=cdrom
memory: 4096
name: Windows-10
net0: virtio=D2:67:F4:C4:D3:8B,bridge=vmbr0
numa: 0
ostype: win10
scsihw: virtio-scsi-pci
smbios1: uuid=81651f08-6c65-4a7f-8b09-0839c8774707
sockets: 1
vga: qxl,memory=32
virtio0: local-zfs:vm-100-disk-0,cache=writeback,iothread=1,size=64G

I am using the latest release, ProxMox 5.3. CPU is Ryzen 7 1800X, MB AsRock AB350 Pro4. Win 10 on guest fully updated but Windows not yet activated.

I used the GUI to configure the DVD drive for the VM. I used the same process to mount ISOs for the OS and Virtio driver install and mounting ISOs worked fine. However, using the internal DVD drive on the host does not work. I confirmed the DVD drive works fine using another computer. I also replicated same issue with a different DVD drive that was also known to work and using a different SATA port on the motherboard. Do you have any ideas what the problem could be?
 
Did you ever sort this? I have a similar issue in that a DVD drive passed through has total read errors on nearly every CD / DVD I try, but if i boot directly to W10 (not in a VM, and without changing any hardware), the discs read perfectly with no errors. Any ideas?
 
Have you tried q35 and/ or i440fx chipset for the VM?
Does it make a difference?
 
I think that passing the optical drive to a VM using the web GUI only works for data not for video playback or burning discs. The only way I could get that working was PCI passthrough of a SATA controller or passing through a USB port and using a USB-to-SATA adapter. Maybe some people got it working using iSCSI from host to VM.
Have a search on this forum to find more posts about using the host optical drive with VMs.
 
I agree with you on the "burning" aspect, but video/DVD is in the end just data as well.
 
I agree with you on the "burning" aspect, but video/DVD is in the end just data as well.
Except when the DVD uses CSS, which in my experience is all commercial videos on DVD. Instead of using passthrough, you maybe could use dvdbackup and genisofs to make a copy and mount the resulting (decrypted) ISO-file in the virtual drive of the VM. Such a work-around (around any DRM protection) can be illegal in many places.
PS: If anyone can playback common store-bought commercial DVD or Blu-ray discs without PCI or USB passthrough or copying, I would really like to know.
 
Last edited:
I've been trying to copy data off self burned DVDs / CDs - they have not worked 99% of the time when passed through, but the disc and drive is fine as it works when booted directly into Windows 10 and accessing the same hardware without any VM / Proxmox. Which is very frustrating!
 
Has anyone found a resolution to this? I have attached a DVD/CD RW drive via USB and it shows up in Windows 10. But the contents of the disk are not read. Inserting the disk into my iMac, I can see and read the contents fine, but I need Windows to execute it.

UPDATE: This was an issue with that particular burnt CD. Replaced it with a software disk and it read fine.

All I did was attach the USB external DVD drive to my Proxmox box, then go into the Windows VM and add USB device, finding the USB port. Rebooted VM and it recognized no problem.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!