Dual LAN card proxmox setup - anybody's using ?

chudak

Active Member
May 11, 2019
302
14
38
I am about to become a new member of proxmox happy users family (awaiting for h/w to arrive)

Wonder if someone can share experiences and/or point me to some resources on how to setup proxmox with to LAN ports.
I watched some videos and feel that bonding is an option for me atm but pen for suggestions.

PS: it'd be interesting to see if proxmox automatically recognize 2 LANs ?

Thx
 
Last edited:
PVE uses static network configuration by default, so the IP you set in the installer will be assigned to the first NIC it finds. But you can of course set up multiple adapters by creating a "Linux Bridge" (vmbr) on them and assigning an IP and subnet. This can be done via the GUI under "<Node> -> System -> Network -> Create".
 
You can also manage Linux Bonds via our GUI under the same path. A bond will only have one IP though, that's the idea of the bond, and whatever devices it's connected to also needs to understand the bond mode you're using. In general this is using the regular Linux Bond capabilities though, so you should be able to look up guides on how to do that for Debian (or just search around here on the forum :) )
 
I was only giving general advice, specific setups always depend on the situation - you can only really figure that part out yourself.

Edit: Though maybe someone else from the forum could comment on how they do it :)
 
i can tell you its a real painnn

i was able to get the bridge working but i have Intrent accses on only one of them....

the starnge thing is that some VMs have internet some done ....
 
A bond is pretty straight forward.
Do as @Stefan_R told you:

Install Proxmox with the default settings.
It binds the IP you enter to the first NIC it finds (more specifically "vmbr" a linux-bridge)

As you enter the Proxmox-Webpage, go to your Host -> System -> Network

It looks something like this (this is my finished setup, so it looks a bit different to yours now):
pmx-network_01.gif

You should see 2 enx* ports (depending on the manufacturer of the NICs) and 1 vmbr0.


Click "Create" and choose "Linux-Bond":
pmx-network_02.gif

Enter the names of both NIC ports (separated by space).
As "Mode" choose e.g. LACP, it's probably the most common protocol, but make sure, your hardware on the other side (your switch) supports that as well.
"Hash-policy": I chose "Layer 2+3" cause it makes the most sense to me.


Now you edit your vmbr0 to use the bond instead of the physical NIC port:
pmx-network_03.gif
Here you should still see your IP, if not re-enter it.
As "Bridge ports" enter your bond e.g. bond0.

"VLAN aware" only needs to be checked if your network makes use of VLANs.


That's it. Your bond is setup and should work without issues.
 
  • Like
Reactions: chudak
@Arvyr
That's what I need, thx !
I will have more questions when I get to actually do it.

How do I make sure my hardware supports LACP? I don't have a managed switch if that's what it takes.

After all is done, where do you connect Ethernet cables from LANs different switches ?
 
If your switch is unmanaged, then I assume port-bundling isn't working anyway.
If it's for your own network or lab environment, then look on ebay for e.g a Cisco Switch.
I bought several from there and they all support LACP.

And pls explain the last question, cause I don't get what you want to ask here.
I mean, you have two ports on your server and need two configured ports on your switch.

Let me quickly show you how to enable LACP on a Cisco Switch (I assume you want VLANs, so we're setting up a trunk):

Code:
! reset interfaces is recommended to clear old configs
(config)# default interface range gi0/1-2
(config)# interface range gi0/1-2
! active is LACP
(config-if)# channel-group 1 mode active

(config-if)# interface port-channel 1
(config-if)# description ## LACP-Bond to Proxmox ##
! on newer switches, the dot1q-command is obsolete/not supported
(config-if)# switchport trunk encapsulation dot1q
(config-if)# switchport mode trunk
! enter your VLANs here
(config-if)# switchport trunk allowed vlans <vlanid1, vlanid2, ...>
! for security reasons, change the native vlan (standard is 1) to something else that's not used
(config-if)# switchport trunk native vlan <vlanid>
! deactivate port-negotiation for security reasons
(config-if)# switchport nonegotiate
! the device on the other side is a host (server), deactivate STP, it's not needed here.
(config-if)# spanning-tree portfast trunk
! we ignore BPDUs on this interface
(config-if)# spanning-tree bpdufilter enable
(config-if)# exit

! load-balance mode, src-dst-mac is also ok, depending on the use-case
(config)# port-channel load-balance src-dst-ip


Access-Mode variant:

Code:
(config-if)# interface port-channel 1
(config-if)# description ## LACP-Bond to Proxmox ##
(config-if)# switchport mode access
! enter your VLAN here
(config-if)# switchport access vlan <vlanid>
! deactivate port-negotiation for security reasons
(config-if)# switchport nonegotiate
! the device on the other side is a host (server), deactivate STP, it's not needed here.
(config-if)# spanning-tree portfast
! we ignore BPDUs on this interface
(config-if)# spanning-tree bpdufilter enable
(config-if)# exit
 
Last edited:
To the same switch of course...weird question tbh.
You could also configure a router with etherchannel, but you need a model with 3 ports or more then and it also has to be managed.

What was your intention in the first place?
Where did you wanted to connect the server to?
 
What was your intention in the first place?
Where did you wanted to connect the server to?

That's actually what I am trying to figure out. I am expecting delivery of new box which has two gigabyte ports, so trying to understand how to use them. If it's easy to double capacity and improve redundancy that'd be great.

What would be your suggestion ?
 
If it's for your personal use only, then you should start with basics.
If you don't even know where to put an ethernet cable or what your network structur is supposed to look like,
etherchannels are the last thing to think of.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!