Disk spin down

TCB13

New Member
Nov 9, 2017
4
0
1
40
Hello,

I've been testing Proxmox and so far everything is just perfect, however I can't find a way to spin down a specific hard drive.

Use case: There's an hard drive on the system I want to use to run daily backups and it shouldn't be on all the time.

I've tried the standard route and did the following to mount at boot and make it spin down.

1. Edited: /etc/fstab
/dev/sda1 /mnt/backups/SU1 ext4 errors=remount-ro,noatime 0 2

2. Added at: /etc/hdparm.conf

/dev/sda {
spindown_time = 60
apm = 127
}

3. Added the storage as a directory using the webUI.

And the HD is always rotating no spin down. I've also noticed that running hdparm -y /dev/sda doesn't do anything, while hdparm -Y /dev/sda spins it down but it comes up right after (1-2 seconds).

Why is this happening? There are currently no running VMs/Containers on the machine or anything else, I did a fresh install.

Thank you!
 

TCB13

New Member
Nov 9, 2017
4
0
1
40
Hi,
I'm not sure, but I think the reason for spinning up is that pve control all defined storages... If you disable the storage first, does the disk spindown work?

Udo

I just tried to disable it on the storage list and the same thing happens. Also noticed another strange behavior, if I unmount the HD with
umount /dev/sda1 I'm still unable to do hdparm -y /dev/sda or hdparm -Y /dev/sda. It seems like my problem is not related promox software, maybe something kernel level?

Thanks.
 

TCB13

New Member
Nov 9, 2017
4
0
1
40
PS: I'm getting this on the syslog when the disk goes up again:
kernel: [ 226.185974] ata3.00: exception Emask 0x0 SAct 0x100000 SErr 0x0 action 0x6

Maybe it is somehow related to the issue? Any tips?
 
Apr 2, 2017
6
2
8
Hallo,

I'm interested in the same toppic. I Have a single disk as Backup for the VMs. It is only used if proxmox is doing a backup once a week. Of course, it is note proved that the backup hard drive will crash, but therefore i do a second backup to a different site once a week as well. Since it is a home server I'm focus on power saving as well.

So the hard drive is mounted straight forward like 1995 stile. If I run
Code:
hdparm -y /dev/sdd
the drive spin down but comes up right after a second. It does the same if i removed the storage from proxmox and even unmounted it. There is no entry for that device in
Code:
/etc/pve/storage.cfg

How can I spin down a certain disk?
 
Last edited:

PigLover

Well-Known Member
Apr 8, 2013
117
36
48
The problem is the Proxmox Stats Deamon (pvestatd). It checks stats on all of your drives - and it does it rather frequently.

You can get your drives to spin down if you turn it off:

#pvestatd disable

But if you do then you will also loose all of the statistics on the "summary" page and if you are forwarding stats to an outside monitor (grafana, etc) they will stop too.

What Proxmox really needs (and I think it needs it pretty badly) is a feature on the "disk" page with a checkbox for each drive to enable/disable statistics/smartctl checks individually by drive. This would allow the rest of the PVE statistics to keep working while not interfering or needlessly accessing drives that might be used for non-Proxmox purposes like embedded file sharing or semi-cold storage.
 
  • Like
Reactions: sebcbien

drdownload

Member
Sep 7, 2017
38
1
13
40
Hi, any news on this? I have data that isnt accessed in months and it would really make cooling easier in this server if the disks would not run all the time.

My solution to passthrough the sata controller to a VM which uses plain debian to spin down is also not very elegant ;)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!