[SOLVED] Debian LXC doesn't start after power outage (pve node reboot ok)


New Member
Jun 1, 2023

I am new to LXC containers and set up a Debian 11 (official template) LXC for haproxy.

I don't have any UPS at the moment and suffered two power outages on two different days. When the power outage is short, my hardware reboot when the power come back and Proxmox and all my VM restart without any problem.

But each time, the LXC doesn't restart, I had to do it manually. As it will be my new reverse proxy with haproxy, it is inconvenient.

I have read some similar cases on the forum without finding the solution.

Here are some details:

# pveversion -v
proxmox-ve: 7.4-1 (running kernel: 5.15.107-2-pve)
pve-manager: 7.4-3 (running version: 7.4-3/9002ab8a)
pve-kernel-5.15: 7.4-3
pve-kernel-5.15.107-2-pve: 5.15.107-2
pve-kernel-5.15.107-1-pve: 5.15.107-1
pve-kernel-5.15.30-2-pve: 5.15.30-3
ceph-fuse: 15.2.16-pve1
corosync: 3.1.7-pve1
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown2: 3.1.0-1+pmx4
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.24-pve2
libproxmox-acme-perl: 1.4.4
libproxmox-backup-qemu0: 1.3.1-1
libproxmox-rs-perl: 0.2.1
libpve-access-control: 7.4-3
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.4-1
libpve-guest-common-perl: 4.2-4
libpve-http-server-perl: 4.2-3
libpve-rs-perl: 0.7.6
libpve-storage-perl: 7.4-2
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 5.0.2-2
lxcfs: 5.0.3-pve1
novnc-pve: 1.4.0-1
proxmox-backup-client: 2.4.2-1
proxmox-backup-file-restore: 2.4.2-1
proxmox-kernel-helper: 7.4-1
proxmox-mail-forward: 0.1.1-1
proxmox-mini-journalreader: 1.3-1
proxmox-offline-mirror-helper: 0.5.1-1
proxmox-widget-toolkit: 3.7.0
pve-cluster: 7.3-3
pve-container: 4.4-3
pve-docs: 7.4-2
pve-edk2-firmware: 3.20230228-2
pve-firewall: 4.3-2
pve-firmware: 3.6-5
pve-ha-manager: 3.6.1
pve-i18n: 2.12-1
pve-qemu-kvm: 7.2.0-8
pve-xtermjs: 4.16.0-1
qemu-server: 7.4-3
smartmontools: 7.2-pve3
spiceterm: 3.2-2
swtpm: 0.8.0~bpo11+3
vncterm: 1.7-1
zfsutils-linux: 2.1.11-pve1

# pct config 102
arch: amd64
cores: 1
features: nesting=1
hostname: haproxy
memory: 1024
net0: name=eth0,bridge=vmbr2,firewall=1,gw=192.168.X.254,hwaddr=XX:XX:XX:XX:XX:XX,ip=192.168.X.250/24,type=veth
ostype: debian
parent: HAProxy_without_conf
rootfs: local-lvm:vm-102-disk-0,size=8G
swap: 512
unprivileged: 1

# systemctl status pve-container@102.service
● pve-container@102.service - PVE LXC Container: 102
     Loaded: loaded (/lib/systemd/system/pve-container@.service; static)
     Active: inactive (dead)
       Docs: man:lxc-start

Jun 02 22:34:33 pve systemd[1]: Started PVE LXC Container: 102.
Jun 02 23:00:30 pve systemd[1]: pve-container@102.service: Succeeded.

The Proxmox node Debian is up to date.

Thank you for your help.


  • lxc-102.log
    18.8 KB · Views: 2
I might be completely misunderstanding your issue but have you tried enabling Start at boot in Options of the container? That would start the container when Proxmox starts (or reboots).
EDIT: I did not see onboot: 1 in the configuration but maybe it's in the parent (in which case my reply is useless)?
Last edited:
  • Like
Reactions: Carizoeuf


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!