Container's network erratic behavior...

Zamana

Well-Known Member
Dec 20, 2015
74
0
46
55
Hi!

I installed Proxmox on a corporate environment in order to use it exclusively for managing containers (our VMs are already managed by VMWare...).

The network is working, but I realize that my containers stop to respond to external pings for long periods of time, but not when I'm pinging from inside them to other IPs in the corporate network at the same time. It seems that the container networks enters in a kind of "suspended mode" or something like this.

Is this a feature or am I doing something wrong?

Where should I look to start troubleshooting this behavior?

Thanks.
Regards.
 
Did you enable the firewall?
 
Hi!

Thanks for reply.

No. Everything that could restrict communication is disabled to minimize any interference.
 
Duplicate MAC or IP perhaps? You could post the network configs but make sure public IPs and other sensitive information is redacted.
 
Yes, we thought that could be a case of duplicated MAC/IP, but it is not. Double checked.

Here is the network part of our configuration.
 

Attachments

  • monitorr.png
    monitorr.png
    24.2 KB · Views: 5
  • pve.png
    pve.png
    30 KB · Views: 4
  • syspass.png
    syspass.png
    24.3 KB · Views: 4
Could you post your /etc/network/interfaces as well as the output of 'ip a' and 'ip r'?

In addition, can you describe your network setup (physical interfaces, switches in use, etc.) a bit more?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!