Containers and vms auto start after manual shutdown

Perkinje

New Member
May 30, 2023
9
2
3
I'm new to Proxmox, coming from a few years using TrueNAS Core/Scale. I'm running a single instance of Proxmox VE 7.4-3 (Linux proxmox 5.15.107-2-pve #1 SMP PVE 5.15.107-2 (2023-05-10T09:10Z) x86_64 GNU/Linux). It's on old desktop hardware: Gigabyte F1 mobo, Intel i7-6700k CPU @ 4.00GHz, 32GB DDR4 Ram, 500GB nvme boot drive, 120GB SSD for ISOs, single 6TB HDD for storage.

As per the title, my containers and vms will auto start themselves after I manually shut them down. I can see options to auto-start when the server boots but I don't see where to stop them from restarting by themselves. I've added a screenshot of the task that restarted one of the containers.

Screenshot 2023-05-29 at 5.26.33 PM.png

Here's a screenshot of the container "Options"

Screenshot 2023-05-29 at 5.29.07 PM.png

The containers restart within 5 minutes of being shutdown. Can anyone explain why the containers restart by themselves and how to stop this?
 
  • Like
Reactions: speeDDemon_AU
I am experiencing the same issue.

Manually shutting down VM's and LXC containers, and they are starting up on their own. Fresh install of Proxmox 7.4 around 1 week ago.
 
did you configure them under ha maybe?
 

Attachments

  • Screenshot 2023-05-31 at 5.42.26 AM.png
    Screenshot 2023-05-31 at 5.42.26 AM.png
    18.8 KB · Views: 47
  • Screenshot 2023-05-31 at 5.42.36 AM.png
    Screenshot 2023-05-31 at 5.42.36 AM.png
    13.8 KB · Views: 39
  • Screenshot 2023-05-31 at 5.42.44 AM.png
    Screenshot 2023-05-31 at 5.42.44 AM.png
    11.6 KB · Views: 38
did you configure them under ha maybe?
Actually just checked under the "more" drop down list for one of the containers and under "Manage HA" the requested state was "started". This seems to be the culprit but I didn't set this. It seems to be the default even though, I haven't messed with the system HA. Thanks for the help.
 
Actually just checked under the "more" drop down list for one of the containers and under "Manage HA" the requested state was "started". This seems to be the culprit but I didn't set this. It seems to be the default even though, I haven't messed with the system HA. Thanks for the help.
no if you open that window it does not mean it's configured, the screenshots you provided show that no ha was configured

can you post the journal/syslog from the time the vm starts unwanted ?
 
no if you open that window it does not mean it's configured, the screenshots you provided show that no ha was configured

can you post the journal/syslog from the time the vm starts unwanted ?

May 31 06:05:06 proxmox pct[2917008]: <root@pam> starting task UPID:proxmox:002C82A5:00EF5B73:64774602:hastart:102:root@pam: May 31 06:05:06 proxmox pct[2917008]: <root@pam> end task UPID:proxmox:002C82A5:00EF5B73:64774602:hastart:102:root@pam: OK May 31 06:05:06 proxmox pve-ha-crm[1419]: service 'ct:102': state changed from 'stopped' to 'request_start' (node = proxmox) May 31 06:05:06 proxmox pve-ha-crm[1419]: service 'ct:102': state changed from 'request_start' to 'started' (node = proxmox) May 31 06:05:09 proxmox pve-ha-lrm[2917073]: starting service ct:102 May 31 06:05:09 proxmox pve-ha-lrm[2917073]: <root@pam> starting task UPID:proxmox:002C82D3:00EF5CCD:64774605:vzstart:102:root@pam: May 31 06:05:09 proxmox pve-ha-lrm[2917075]: starting CT 102: UPID:proxmox:002C82D3:00EF5CCD:64774605:vzstart:102:root@pam: May 31 06:05:10 proxmox systemd[1]: Started PVE LXC Container: 102. May 31 06:05:10 proxmox kernel: EXT4-fs (dm-6): mounted filesystem with ordered data mode. Opts: (null). Quota mode: none. May 31 06:05:10 proxmox audit[2917117]: AVC apparmor="STATUS" operation="profile_load" profile="/usr/bin/lxc-start" name="lxc-102_</var/lib/lxc>" pid=2917117 comm="apparmor_parser" May 31 06:05:10 proxmox kernel: audit: type=1400 audit(1685538310.620:77): apparmor="STATUS" operation="profile_load" profile="/usr/bin/lxc-start" name="lxc-102_</var/lib/lxc>" pid=2917117 comm="apparmor_parser" May 31 06:05:10 proxmox systemd-udevd[2917080]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable. May 31 06:05:10 proxmox systemd-udevd[2917080]: Using default interface naming scheme 'v247'. May 31 06:05:10 proxmox kernel: vmbr0: port 4(veth102i0) entered blocking state May 31 06:05:10 proxmox kernel: vmbr0: port 4(veth102i0) entered disabled state May 31 06:05:10 proxmox kernel: device veth102i0 entered promiscuous mode May 31 06:05:10 proxmox kernel: eth0: renamed from veth1kXrBK May 31 06:05:11 proxmox pve-ha-lrm[2917073]: <root@pam> end task UPID:proxmox:002C82D3:00EF5CCD:64774605:vzstart:102:root@pam: OK May 31 06:05:11 proxmox pve-ha-lrm[2917073]: service status ct:102 started May 31 06:05:11 proxmox kernel: IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready May 31 06:05:11 proxmox kernel: vmbr0: port 4(veth102i0) entered blocking state May 31 06:05:11 proxmox kernel: vmbr0: port 4(veth102i0) entered forwarding state May 31 06:05:11 proxmox pvestatd[1382]: modified cpu set for lxc/102: 1

This looks like HA is where the restart request is coming from.
 
yes looks like it, weird that your ha config in the webui does not show it...
what does

Code:
ha-manager status
ha-manager config
say?
 
yes looks like it, weird that your ha config in the webui does not show it...
what does

Code:
ha-manager status
ha-manager config
say?
ha-manager status
quorum OK master proxmox (active, Wed May 31 06:13:36 2023) lrm proxmox (active, Wed May 31 06:13:29 2023)
but I think it would have just been "quorum OK" if I hadn't been messing with the container ha settings in the last few minutes.

ha-manager config
returns no results
 
Also, if I tell ha to ignore the container and shut it down, it still restarts.
can you once again post the journal from when you set it do ignored in ha until after the guest starts?
 
If you intend to utilize just one node, you can deactivate unnecessary HA services by executing the following commands:

Stop and disable the Proxmox VE HA Local Resource Manager
Bash:
systemctl stop pve-ha-lrm
systemctl disable pve-ha-lrm

Stop and disable the Proxmox VE HA Cluster Resource Manager
Bash:
systemctl stop pve-ha-crm
systemctl disable pve-ha-crm

Stop and disable the Proxmox VE Corosync Cluster Engine
Bash:
systemctl stop corosync
systemctl disable corosync
 
Last edited:
can you once again post the journal from when you set it do ignored in ha until after the guest starts?
Jun 02 18:31:20 proxmox pct[2560875]: <root@pam> starting task UPID:proxmox:xxx:vzstart:114:root@pam: Jun 02 18:31:20 proxmox pct[2560876]: starting CT 114: UPID:proxmox:xxx:vzstart:114:root@pam: Jun 02 18:31:21 proxmox systemd[1]: Started PVE LXC Container: 114. Jun 02 18:31:21 proxmox kernel: EXT4-fs (dm-9): mounted filesystem with ordered data mode. Opts: (null). Quota mode: none. Jun 02 18:31:22 proxmox audit[2560910]: AVC apparmor="STATUS" operation="profile_load" profile="/usr/bin/lxc-start" name="lxc-114_</var/lib/lxc>" pid=2560910 comm="apparmor_parser" Jun 02 18:31:22 proxmox kernel: audit: type=1400 audit(1685755882.043:89): apparmor="STATUS" operation="profile_load" profile="/usr/bin/lxc-start" name="lxc-114_</var/lib/lxc>" pid=2560910 comm="apparmor_parser" Jun 02 18:31:22 proxmox systemd-udevd[2560883]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable. Jun 02 18:31:22 proxmox systemd-udevd[2560883]: Using default interface naming scheme 'v247'. Jun 02 18:31:22 proxmox kernel: vmbr0: port 8(veth114i0) entered blocking state Jun 02 18:31:22 proxmox kernel: vmbr0: port 8(veth114i0) entered disabled state Jun 02 18:31:22 proxmox kernel: device veth114i0 entered promiscuous mode Jun 02 18:31:22 proxmox kernel: eth0: renamed from veth0FUGUh Jun 02 18:31:22 proxmox pct[2560875]: <root@pam> end task UPID:proxmox:xxx:vzstart:114:root@pam: OK
 
If you intend to utilize just one node, you can deactivate unnecessary HA services by executing the following commands:

Stop and disable the Proxmox VE HA Local Resource Manager
Bash:
systemctl stop pve-ha-lrm
systemctl disable pve-ha-lrm

Stop and disable the Proxmox VE HA Cluster Resource Manager
Bash:
systemctl stop pve-ha-crm
systemctl disable pve-ha-crm

Stop and disable the Proxmox VE Corosync Cluster Engine
Bash:
systemctl stop corosync
systemctl disable corosync

I ran these commands but container still restarts. Here is the syslog:

Jun 02 18:47:19 proxmox pct[2579706]: <root@pam> starting task UPID:proxmox:xxx:vzstart:114:root@pam: Jun 02 18:47:19 proxmox pct[2579708]: starting CT 114: UPID:proxmox:xxx:vzstart:114:root@pam: Jun 02 18:47:20 proxmox systemd[1]: Started PVE LXC Container: 114. Jun 02 18:47:20 proxmox kernel: EXT4-fs (dm-11): mounted filesystem with ordered data mode. Opts: (null). Quota mode: none. Jun 02 18:47:20 proxmox audit[2579742]: AVC apparmor="STATUS" operation="profile_load" profile="/usr/bin/lxc-start" name="lxc-114_</var/lib/lxc>" pid=2579742 comm="apparmor_parser" Jun 02 18:47:20 proxmox kernel: audit: type=1400 audit(1685756840.651:93): apparmor="STATUS" operation="profile_load" profile="/usr/bin/lxc-start" name="lxc-114_</var/lib/lxc>" pid=2579742 comm="apparmor_parser" Jun 02 18:47:20 proxmox systemd-udevd[2579715]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable. Jun 02 18:47:20 proxmox systemd-udevd[2579715]: Using default interface naming scheme 'v247'. Jun 02 18:47:21 proxmox kernel: vmbr0: port 11(veth114i0) entered blocking state Jun 02 18:47:21 proxmox kernel: vmbr0: port 11(veth114i0) entered disabled state Jun 02 18:47:21 proxmox kernel: device veth114i0 entered promiscuous mode Jun 02 18:47:21 proxmox kernel: eth0: renamed from vethW4nESm Jun 02 18:47:21 proxmox pct[2579706]: <root@pam> end task UPID:proxmox:xxx:vzstart:114:root@pam: OK
 
I ran these commands but container still restarts. Here is the syslog:

Jun 02 18:47:19 proxmox pct[2579706]: <root@pam> starting task UPID:proxmox:xxx:vzstart:114:root@pam: Jun 02 18:47:19 proxmox pct[2579708]: starting CT 114: UPID:proxmox:xxx:vzstart:114:root@pam: Jun 02 18:47:20 proxmox systemd[1]: Started PVE LXC Container: 114. Jun 02 18:47:20 proxmox kernel: EXT4-fs (dm-11): mounted filesystem with ordered data mode. Opts: (null). Quota mode: none. Jun 02 18:47:20 proxmox audit[2579742]: AVC apparmor="STATUS" operation="profile_load" profile="/usr/bin/lxc-start" name="lxc-114_</var/lib/lxc>" pid=2579742 comm="apparmor_parser" Jun 02 18:47:20 proxmox kernel: audit: type=1400 audit(1685756840.651:93): apparmor="STATUS" operation="profile_load" profile="/usr/bin/lxc-start" name="lxc-114_</var/lib/lxc>" pid=2579742 comm="apparmor_parser" Jun 02 18:47:20 proxmox systemd-udevd[2579715]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable. Jun 02 18:47:20 proxmox systemd-udevd[2579715]: Using default interface naming scheme 'v247'. Jun 02 18:47:21 proxmox kernel: vmbr0: port 11(veth114i0) entered blocking state Jun 02 18:47:21 proxmox kernel: vmbr0: port 11(veth114i0) entered disabled state Jun 02 18:47:21 proxmox kernel: device veth114i0 entered promiscuous mode Jun 02 18:47:21 proxmox kernel: eth0: renamed from vethW4nESm Jun 02 18:47:21 proxmox pct[2579706]: <root@pam> end task UPID:proxmox:xxx:vzstart:114:root@pam: OK
Are you running the Proxmox VE Monitor-All script obtained from helper-scripts.com?
 
Ugh, I shot myself in the foot with this also! I was doing some filesystem work and my containers started back up in the middle of moving them.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!