ceph pool creation missing input validation, how do I fix it?

ravib123

Active Member
Nov 27, 2012
47
0
26
United States
deusmachine.com
I was making some new ceph pools in the web gui and it doesn't perform validation on the inputs.

As it turns out I used some characters that blew the scripts up.

The entries seem to only exist in the web gui but I can't figure out how to remove them because the web gui wont remove them.

It produces this error:
Method 'DELETE path not implemented (501)
(actual path left out on purpose)

Ideas?
 

wolfgang

Proxmox Retired Staff
Retired Staff
Oct 1, 2014
6,496
496
103
Hi,

what you get with this command?

ceph osd lspools

and here with this command you can erase it

ceph osd pool delete <poolname>
 

ravib123

Active Member
Nov 27, 2012
47
0
26
United States
deusmachine.com
Awesome, that worked despite the special characters and cleaned up the GUI.

Thanks.

Definitely worth putting on your bug list to put some validation on those input boxes for the forgetful folks like me :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!