Ceph enterprise not working

Thomas Stone

Well-Known Member
Mar 8, 2016
58
2
48
Hello:

I have a license at the lowest cost Proxmox VE subscription level. I installed fresh Proxmox 8 in the last few days of the beta, then updated to release.

I removed my license from my old box and added it to the new one -- no problem. I can get packages from the enterprise repo. But not for Ceph. For Ceph I get errors:

Code:
W: Skipping acquire of configured file 'enterprise/binary-amd64/Packages' as repository 'http://download.proxmox.com/debian/ceph-quincy bookworm InRelease' doesn't have the component 'enterprise' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'enterprise/i18n/Translation-en_US' as repository 'http://download.proxmox.com/debian/ceph-quincy bookworm InRelease' doesn't have the component 'enterprise' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'enterprise/i18n/Translation-en' as repository 'http://download.proxmox.com/debian/ceph-quincy bookworm InRelease' doesn't have the component 'enterprise' (component misspelt in sources.list?)

If I change /etc/apt/sources.list.d/ceph.list to no-subscription, I can update without errors. I don't use Ceph so probably doesn't matter, but curious how to properly fix the problem. Thank you.
 
The correct sources.list should be:
deb https://enterprise.proxmox.com/debian/ceph-quincy bookworm enterprise
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!