Can't proceed any backup


Jun 16, 2020

i'm having an issue with my automatic script backing up 15 VMs in the same time.
So i tried to specifically backup only one, so i got this message and i don't understand why it's blocking:

root@pve:~# vzdump 100 --node pve --storage backupStorage --remove 0 --mode snapshot --compress zstd
INFO: starting new backup job: vzdump 100 --node pve --mode snapshot --remove 0 --storage backupStorage --compress zstd
INFO: Starting Backup of VM 100 (lxc)
INFO: Backup started at 2020-11-22 14:36:56
INFO: status = running
INFO: CT Name: plex
INFO: including mount point rootfs ('/') in backup
INFO: excluding bind mount point mp0 ('/plex/4TO1') from backup (not a volume)
INFO: excluding bind mount point mp1 ('/plex/photos') from backup (not a volume)
INFO: excluding bind mount point mp2 ('/plex/Deluge') from backup (not a volume)
INFO: found old vzdump snapshot (force removal)
lvremove snapshot 'pve/snap_vm-100-disk-0_vzdump' error:   Failed to find logical volume "pve/snap_vm-100-disk-0_vzdump"
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: create storage snapshot 'vzdump'
found lock 'snapshot' trying to remove 'backup' lock
ERROR: Backup of VM 100 failed - unable to parse volume ID '/storage/4TO1'
INFO: Failed at 2020-11-22 14:36:56
INFO: Backup job finished with errors
job errors

i share folders whith my container and it worked since 2 month until yersteday.
Moreover, it blocks the 4 first VMs and the other ones are being backup then : i'm rellay lost and i don't understand that.

Thank you in advance for your help.
I am having the same issue with one of my containers that is using shared storage. It worked fine until a couple of days ago. I suspect an update broke something? I am using subscription service.

proxmox-ve: 6.2-2 (running kernel: 5.4.73-1-pve)
pve-manager: 6.2-15 (running version: 6.2-15/48bd51b6)
pve-kernel-5.4: 6.3-1
pve-kernel-helper: 6.3-1
pve-kernel-5.3: 6.1-6
pve-kernel-5.0: 6.0-11
pve-kernel-5.4.73-1-pve: 5.4.73-1
pve-kernel-5.4.65-1-pve: 5.4.65-1
pve-kernel-5.3.18-3-pve: 5.3.18-3
pve-kernel-5.0.21-5-pve: 5.0.21-10
pve-kernel-5.0.15-1-pve: 5.0.15-1
ceph: 14.2.11-pve1
ceph-fuse: 14.2.11-pve1
corosync: 3.0.4-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.16-pve1
libproxmox-acme-perl: 1.0.5
libpve-access-control: 6.1-3
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.2-4
libpve-guest-common-perl: 3.1-3
libpve-http-server-perl: 3.0-6
libpve-storage-perl: 6.2-10
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.3-1
lxcfs: 4.0.3-pve3
novnc-pve: 1.1.0-1
proxmox-backup-client: 1.0.1-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.3-10
pve-cluster: 6.2-1
pve-container: 3.2-3
pve-docs: 6.2-6
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-3
pve-firmware: 3.1-3
pve-ha-manager: 3.1-1
pve-i18n: 2.2-2
pve-qemu-kvm: 5.1.0-6
pve-xtermjs: 4.7.0-2
qemu-server: 6.2-20
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 0.8.5-pve1
I’ve updated my system today as well. I’m getting the same error from vzdump from containers with storage pass through:
unable to parse volume ID
Additionally the vzdump zfs snapshots are generated, that can't be deleted. They show only on Web UI, not via zfs list -t snapshot.
The Containers are being left in locked state, which can be unlocked again with pct unlock <ID>.

Edit: 1606123233832.png

Edit2: The Containers can be backed up, if they are shut down. So the backup mode Snapshot is broken.

Edit3: The way you can delete those "phantom" zfs snapshots is following:
They are being named as "vzdump", so check if you indeed don't have that snapshots with:
zfs list -t snapshot | grep vzdump
If not, create a new snapshot of that container disk, in my case the container have the ID 101:
zfs snapshot rpool/Containers/subvol-101-disk-0@vzdump
Remove the lock, if any:
pct unlock 101
And finally you can delete this snapshots in the Web UI.

Edit4: Another bug in the Web UI, the Web UI must check if the snapshot is indeed created, before showing it on Web UI and letting that in a phantom state.

Edit5: The workaround to the initial problem is downgrading the package:
apt install pve-container=3.2-2
Last edited:
There is a new version of the package 3.2-4. Is this problem fixed with it?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!