Can't pass through Radeon RX 5500

michaelf

Member
Oct 13, 2023
49
1
8
michaelfirsov.wordpress.com
Hello!

I've already asked about passing through GTX 650 here - now I've changed it to Radeon 5500 and didn't even get the result I had gotten with GTX 650:
I can add PCI Card...
01.png


Q.png



...but after changing display to None and logging in to Windows 10 VM I even don't see the passed-through adapter (AMD Radeon) in Device Manager (that was the case with Nvidia).

Of cource I changed the /etc/modprobe.d/vfio.conf file accordingly and created a new VM. All checks (IOMMU, remapping...) = OK.

What am I doing wrong here???

P.S. After cancelling the early binding in vfio.conf I managed to see the adapter in Windows but with the same error 43 :(((

Thank you in advance,
Michael
 

Attachments

  • Q.png
    Q.png
    34.2 KB · Views: 2
Last edited:
Not yet - I don't quite understant should I do it for any VGA card being passed-through (and that would be rather weid as the guides I followed did not require it) or only for some specific cards?
Lots of devices don't reset properly, but for certain AMD GPUs (which are known for reset issues) you can work-around it via vendor-reset. The link that I provided lists the AMD GPUs that it works for. I expect that it will fix your problem but there are never guarantees with passthrough. Best of luck to you.
 
P.S. one more theory question, please: am I getting it right that if the pass-through is working I must be able to see the VM's output if I connect a monitor to the passed-through card (my console is connected to the built-in card)? ...just want to know how this problem (the card can't reset) is look like...

Now I sometimes do see the Windows 10' output (from VM) on the monitor attached to the Radeon - for example I see how the Windows 10 (inside the VM) is booting, can see the "Please press CTRL+ALT+DEL to log on" screen and then the monitor goes blank, sometimes booting the VM does not produce on the monitor anything from VM at all but do produce output from the console that should be visible on the monitor attached to the built-in card - is it this problem?
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!