[SOLVED] Cannot move EFI disk to another storage


Well-Known Member
Mar 4, 2014
my VMs use an EFI disk (in addition to the standard disk).
Now I want to move all disks to another storage.
There's no issue with the standard disk.
However, the option to move the EFI disk is not available in WebUI.
This means, I need drop the EFI disk and re-create it in new storage.
But then I need to stop the VM, which is causing a downtime.

I now for sure that it was possible to move EFI disk to another storage with previous Proxmox release.

I currently run this version:
root@ld3955:~# pveversion --verbose
proxmox-ve: 6.0-2 (running kernel: 5.0.21-2-pve)
pve-manager: 6.0-7 (running version: 6.0-7/28984024)
pve-kernel-5.0: 6.0-8
pve-kernel-helper: 6.0-8
pve-kernel-4.15: 5.4-8
pve-kernel-5.0.21-2-pve: 5.0.21-6
pve-kernel-5.0.21-1-pve: 5.0.21-2
pve-kernel-4.15.18-20-pve: 4.15.18-46
pve-kernel-4.15.18-14-pve: 4.15.18-39
ceph: 14.2.4-pve1
ceph-fuse: 14.2.4-pve1
corosync: 3.0.2-pve2
criu: 3.11-3
glusterfs-client: 5.5-3
libjs-extjs: 6.0.1-10
libknet1: 1.12-pve1
libpve-access-control: 6.0-2
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-5
libpve-guest-common-perl: 3.0-1
libpve-http-server-perl: 3.0-2
libpve-storage-perl: 6.0-9
libqb0: 1.0.5-1
lvm2: 2.03.02-pve3
lxc-pve: 3.1.0-65
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.0-7
pve-cluster: 6.0-7
pve-container: 3.0-7
pve-docs: 6.0-4
pve-edk2-firmware: 2.20190614-1
pve-firewall: 4.0-7
pve-firmware: 3.0-2
pve-ha-manager: 3.0-2
pve-i18n: 2.0-3
pve-qemu-kvm: 4.0.0-5
pve-xtermjs: 3.13.2-1
qemu-server: 6.0-7
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1

Please advise how to move EFI disk to another storage.

I just came across the same bug where the GUI "Move Disk" icon for an EFI disk on NFS storage is greyed out. As per the above suggestion the following shell command worked for me to move the EFI disk to local zfs storage:

qm move_disk <VMID> efidisk0 local-zfs

Assume this will be fixed in a future PVE update?
Did this make it into 7.1-7 as this bug is still present in the GUI moving the efidisk0. Is there a bug repository we can track the status of this? I'm moving from NFS to rbd.
Did this make it into 7.1-7 as this bug is still present in the GUI moving the efidisk0. Is there a bug repository we can track the status of this? I'm moving from NFS to rbd.
the report here was about not being able to even start the operation from the GUI. That was fixed. Are you maybe running into:
https://bugzilla.proxmox.com/show_bug.cgi?id=3227#c13 ? As a workaround, you need to offline move the disk. QEMU's live drive-mirror is strict and requires the exact same size for source and target. Ceph needs to allocate at least 4MiB and if the source image is smaller, it doesn't work.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!