backup of container fails? [solved]


Nov 27, 2018
Hey folks, running 6.0-7

In the gui, I select a container (linux running centos6.x) for backup and I get the following..
INFO: starting new backup job: vzdump 103 --node newrock --mode snapshot --storage backups --remove 0 --compress lzo
INFO: Starting Backup of VM 103 (lxc)
INFO: Backup started at 2019-10-06 13:09:51
INFO: status = running
INFO: CT Name: ritas-server
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: create storage snapshot 'vzdump'
INFO: creating archive '/mnt/pve/backups/dump/vzdump-lxc-103-2019_10_06-13_09_51.tar.lzo'
INFO: tar: /mnt/pve/backups/dump/vzdump-lxc-103-2019_10_06-13_09_51.tmp: Cannot open: Permission denied
INFO: tar: Error is not recoverable: exiting now
INFO: remove vzdump snapshot
ERROR: Backup of VM 103 failed - command 'set -o pipefail && lxc-usernsexec -m u:0:100000:65536 -m g:0:100000:65536 -- tar cpf - --totals --one-file-system -p --sparse --numeric-owner --acls --xattrs '--xattrs-include=user.*' '--xattrs-include=security.capability' '--warning=no-file-ignored' '--warning=no-xattr-write' --one-file-system '--warning=no-file-ignored' '--directory=/mnt/pve/backups/dump/vzdump-lxc-103-2019_10_06-13_09_51.tmp' ./etc/vzdump/pct.conf ./etc/vzdump/pct.fw '--directory=/mnt/vzsnap0' --no-anchored '--exclude=lost+found' --anchored '--exclude=./tmp/?*' '--exclude=./var/tmp/?*' '--exclude=./var/run/?*.pid' ./ | lzop >/mnt/pve/backups/dump/vzdump-lxc-103-2019_10_06-13_09_51.tar.dat' failed: exit code 2
INFO: Failed at 2019-10-06 13:09:52
INFO: Backup job finished with errors
TASK ERROR: job errors

There are other backup files written to this directory.. and the log of this backup is in this dir as well.

-rw-r--r-- 1 root root 1403 Oct 6 2019 vzdump-lxc-103-2019_10_06-13_09_51.log

any ideas?

Last edited:
"Fix" how? If you wouldn't mind sharing. I'm having the same issue.

Hey mate,

I had the same issue and what fixed it for me was setting a local temp directory for the backup, and changing the NFS type from 'default' to 'NFS 4.1'
  • Like
Reactions: Hyacin


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!