Attempt to install libcurl4 requires removal of proxmox-ve?

molware

New Member
Dec 2, 2019
6
0
1
22
I'm trying to install curl on my host because for some reason it's not installed, and I'm running into issues....


pveversion shows:
pve-manager/6.0-15/52b91481 (running kernel: 5.0.21-5-pve)

Attempt to run curl shows: curl
-bash: curl: command not found

Attempt to install curl: apt install curl
The following packages have unmet dependencies:
curl : Depends: libcurl4 (= 7.64.0-4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Attempt to fix broken packages: apt-get update --fix-missing
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 http://download.proxmox.com/debian/pve buster InRelease
Hit:3 http://download.proxmox.com/debian/ceph-luminous stretch InRelease
Hit:4 http://ftp.debian.org/debian buster InRelease
Hit:5 http://ftp.debian.org/debian buster-updates InRelease
Reading package lists... Done

Attempt to install libcurl4 dependency: apt install libcurl 4
The following packages were automatically installed and are no longer required:
[Long list of different packages]
The following packages will be REMOVED:
ceph ceph-base ceph-common ceph-mds ceph-mgr ceph-mon ceph-osd libcurl3
libpve-guest-common-perl libpve-storage-perl librgw2 proxmox-ve
pve-container pve-ha-manager pve-manager pve-qemu-kvm python-rgw
qemu-server spiceterm
The following NEW packages will be installed:
libcurl4
0 upgraded, 1 newly installed, 19 to remove and 0 not upgraded.
Need to get 0 B/332 kB of archives.
After this operation, 456 MB disk space will be freed.
Do you want to continue? [Y/n] Y
W: (pve-apt-hook) !! WARNING !!
W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!
W: (pve-apt-hook)
W: (pve-apt-hook) If you really want to permanently remove 'proxmox-ve' from
your system, run the following command
W: (pve-apt-hook) touch '/please-remove-proxmox-ve'
W: (pve-apt-hook) run apt purge proxmox-ve to remove the meta-package
W: (pve-apt-hook) and repeat your apt invocation.
W: (pve-apt-hook)
W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please
verify
W: (pve-apt-hook) - your APT repository settings
W: (pve-apt-hook) - that you are using 'apt full-upgrade' to upgrade yo
ur system
E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1)
E: Failure running script /usr/share/proxmox-ve/pve-apt-hook/

I've never really seen this type of issue before. Some research shows that this issue occurs when trying to install a package that's already part of proxmox-ve package and conflicts so in order to install it tries to remove proxmox. In this case I still can't use curl..... What can I do about this?
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
921
93
28
hi,

did you install PVE on top of debian? you should remove the debian kernel with apt remove linux-image-amd64 'linux-image-4.19*'
 
  • Like
Reactions: molware

molware

New Member
Dec 2, 2019
6
0
1
22
You did something wrong on your update path, you still have stretch packages on your buster.?
I've removed the stretch repository. I was previously editing /etc/apt/sources.list, and didn't notice the additional package in apt/sources.list.d. This hasn't resolved the issue yet unfortunately.
 

molware

New Member
Dec 2, 2019
6
0
1
22
hi,

did you install PVE on top of debian? you should remove the debian kernel with apt remove linux-image-amd64 'linux-image-4.19*'
I did not install on top of debian, I installed proxmox directly(via iso), and updated to 6.0 last month I believe from 5.4.
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
3,583
553
118
having libcurl4 or curl installed is not a problem - your system is probably only partially upgraded. can you post the output of "pveversion -v"?
 

molware

New Member
Dec 2, 2019
6
0
1
22
having libcurl4 or curl installed is not a problem - your system is probably only partially upgraded. can you post the output of "pveversion -v"?
Here is the output:

root@pve:~# pveversion -v
proxmox-ve: 6.0-2 (running kernel: 5.0.21-5-pve)
pve-manager: 6.0-15 (running version: 6.0-15/52b91481)
pve-kernel-helper: 6.0-12
pve-kernel-5.0: 6.0-11
pve-kernel-4.15: 5.3-3
pve-kernel-5.0.21-5-pve: 5.0.21-10
pve-kernel-5.0.21-4-pve: 5.0.21-9
pve-kernel-4.15.18-12-pve: 4.15.18-36
ceph: 12.2.12-pve1
ceph-fuse: 12.2.12-pve1
corosync: 3.0.2-pve4
criu: 3.11-3
glusterfs-client: 5.5-3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.13-pve1
libpve-access-control: 6.0-5
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-9
libpve-guest-common-perl: 3.0-3
libpve-http-server-perl: 3.0-3
libpve-storage-perl: 6.0-12
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve3
lxc-pve: 3.2.1-1
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.1-1
pve-cluster: 6.0-9
pve-container: 3.0-14
pve-docs: 6.0-9
pve-edk2-firmware: 2.20191002-1
pve-firewall: 4.0-8
pve-firmware: 3.0-4
pve-ha-manager: 3.0-5
pve-i18n: 2.0-3
pve-qemu-kvm: 4.1.1-2
pve-xtermjs: 3.13.2-1
qemu-server: 6.1-1
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.2-pve2
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
3,583
553
118
you have ceph packages from our Stretch repository installed, instead of from our Buster repository.
 

molware

New Member
Dec 2, 2019
6
0
1
22
you have ceph packages from our Stretch repository installed, instead of from our Buster repository.
I see. Is there a way to reinstall using the buster repository without breaking anything, or do I need a new install?
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
3,583
553
118
I see. Is there a way to reinstall using the buster repository without breaking anything, or do I need a new install?
you just need to fix your repository configuration (including files in '/etc/apt/sources.list.d') and then run apt update; apt full-upgrade
 

molware

New Member
Dec 2, 2019
6
0
1
22
So, I did an apt update/apt full-upgrade after I removed the stretch repository a few days ago and I am still unable to install libcurl4. I removed all files in /etc/apt/sources.list.d/ and performed apt update;apt full-upgrade.

I tried to install libcurl4 from a local .deb, and it requires libcurl3 to be removed. I try to apt remove libcurl3:amd64, and I get the same "attempting to remove proxmox-ve" error.

It appears that the packages ceph-common and librgw2 depend on libcurl3 which cannot be installed at the same time as libcurl4.

I can install a vast amount of other packages, just not libcurl4 due to the dependency issue.

Here is my sources.list:
There is nothing in /etc/apt/sources.list.d/

Code:
deb http://ftp.debian.org/debian buster main contrib
deb http://ftp.debian.org/debian buster-updates main contrib

# PVE pve-no-subscription repository provided by proxmox.com,
# NOT recommended for production use
deb http://download.proxmox.com/debian/pve buster pve-no-subscription       
# security updates
deb http://security.debian.org/debian-security buster/updates main contrib
Code:
root@pve:~# pveversion -v
proxmox-ve: 6.1-2 (running kernel: 5.3.10-1-pve)
pve-manager: 6.1-3 (running version: 6.1-3/37248ce6)
pve-kernel-5.3: 6.0-12
pve-kernel-helper: 6.0-12
pve-kernel-5.0: 6.0-11
pve-kernel-5.3.10-1-pve: 5.3.10-1
pve-kernel-4.15: 5.3-3
pve-kernel-5.0.21-5-pve: 5.0.21-10
pve-kernel-4.15.18-12-pve: 4.15.18-36
ceph-fuse: 12.2.12-pve1
corosync: 3.0.2-pve4
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.13-pve1
libpve-access-control: 6.0-5
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-9
libpve-guest-common-perl: 3.0-3
libpve-http-server-perl: 3.0-3
libpve-storage-perl: 6.1-2
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve3
lxc-pve: 3.2.1-1
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.1-1
pve-cluster: 6.1-2
pve-container: 3.0-14
pve-docs: 6.1-3
pve-edk2-firmware: 2.20191002-1
pve-firewall: 4.0-9
pve-firmware: 3.0-4
pve-ha-manager: 3.0-8
pve-i18n: 2.0-3
pve-qemu-kvm: 4.1.1-2
pve-xtermjs: 3.13.2-1
qemu-server: 6.1-2
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.2-pve2
Update && full-upgrade

Code:
apt update && apt full-upgrade
Hit:1 http://security.debian.org/debian-security buster/updates InRelease
Hit:2 http://ftp.debian.org/debian buster InRelease
Hit:3 http://ftp.debian.org/debian buster-updates InRelease
Hit:4 http://download.proxmox.com/debian/pve buster InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!