Recent content by le_top

  1. L

    Upgraded pve to 6.8.10-12-pve and containers won't start - 'Failed to clone a new set of namespaces'

    I experienced the same issue on Proxmox VE 8.4.19 with an LXC container failing to backup. After shutting it down, it did not even restart, showing: lxc_spawn: 1738 No space left on device - Failed to clone a new set of namespaces __lxc_start: 2114 Failed to spawn container "112" TASK ERROR...
  2. L

    pve 8.0 and 8.1 hangs on boot

    On an asus I enabled the X2APIC opt-out to no avail. Tried with kernel 6.2 . I managed to get the system functionnal again after several trials and "errors". The following is more or less what worked for me: # 'lsblk' and 'fdisk -l' can help identify the partitions export lang=C export...
  3. L

    pve Linux 6.5.11-7-pve stucks "loading initial ramdisk..."

    Once in the Grub menu, I edited the rescue grub "script" and added "loglevel=7" to the "linux" line and added an echo "Initrd done" after the initrd line. On boot "Initrd done" was shown after "Loading initial ramdisk ..." so the ramdisk is loaded, but it does does not boot next? mkdir r #...
  4. L

    pve Linux 6.5.11-7-pve stucks "loading initial ramdisk..."

    My datacenter just intervened on my server and indicates that the boot is stuck on "Loading initial ramdisk". I tried both copies of the RAID. The server is an Asus machine. I am going to try and modify the kernel used (after checking which was the kernel on installation - I found...
  5. L

    [SOLVED] Is there a cluster bridge or cluster-level networking?

    @Theo70 - This is not exactly the topic of this thread. However, "bridge-ports <IFACE>" is the key. On a server in a datacenter I have: auto vmbr0 iface vmbr0 inet static address <STATIC_IP>/24 gateway <STATIC_GW> bridge-ports enp3s0f0 bridge-stp off...
  6. L

    [SOLVED] apache2.service: Failed to set up mount namespacing: Permission denied

    I created this script (for apache) to add the override to the systemd configuration. Easier to repeat on different servers. #!/bin/bash # run using sudo or root OVERRIDE_FILE=/etc/systemd/system/apache2.service.d/override.conf if [ ! -r "${OVERRIDE_FILE}" ] ; then mkdir -p "$(dirname...
  7. L

    [SOLVED] Is there a cluster bridge or cluster-level networking?

    This is a great feature. I setup a VXNET and to get it fully running on proxmox 8.1.3, I had to do a few things: 1. I added a firewall rule at the datacenter level to accept traffic related to the VXLAN. I probably should define an alias for the machines in the cluster and set that as the...
  8. L

    How to resize /dev/pve/data without breaking Proxmox?

    @kunus Thanks for sharing, still helpful today on Proxmox 8: ```bash resize2fs /dev/mapper/vg-data 100G e2fsck -f /dev/mapper/vg-data resize2fs /dev/mapper/vg-data 100G lvreduce -L100G /dev/mapper/vg-data resize2fs /dev/mapper/vg-data mount /var/lib/vz history ``` However, my ultimate goal...
  9. L

    lxc apparmor="DENIED" operation="mount" error=-13

    I am on Proxmox 8.0.3 after upgrading from an old version. I have these in my log and the machine has number 102, not 200. I wonder if it is getting messages for machine 200: 2023-07-19T17:10:41.454554+00:00 p2 kernel: [81220.449368] audit: type=1400 audit(1689786641.449:6432)...
  10. L

    [Solved] QDevice - service not starting on node

    I am trying to set up a qdevice node to a 2 node setup . I fixed some issues, and I am almost there but the last step fails: node 'p3': Importing cluster certificate and key node 'p3': pk12util: PKCS12 IMPORT SUCCESSFUL node 'p5': Importing cluster certificate and key node 'p5': pk12util...
  11. L

    "Migrating" without syncing disk (after node isolation)

    The machines that were concerened are ct:102 and ct:140. They both use replicated ZFS. Both of their ha-groups were empty after the failure. I can not guarantee that they were set before the failure, but in principle I checked all the settings before . The machines migrated to server p1 which...
  12. L

    "Migrating" without syncing disk (after node isolation)

    This just happened again for two machines. Their groups were "empty". I applied to procedure to manually remove the rootfs from '/etc/pve/nodes/<server>/lxc/*.conf for the machines in question. I then performed the "pct rescan -vmid <ID>" commands to reattache the disks. This attaches the...
  13. L

    "Migrating" without syncing disk (after node isolation)

    When a machine fails, recovery requires several tricks at least 50% of the time. I am using Proxmox VE 5.4-13 and a machine failed, was isolated, etc. Some machines properly migrated, but 3 are in a "difficult" state Two instances migrated to a machine that is not even in the HA cluster that...
  14. L

    IP for machine that was migrated still responding

    This looks similar to https://forum.proxmox.com/threads/turned-off-vm-still-respond-to-ping-and-ssh.25396/ but I am running "pve-manager/5.4-5/c6fdb264 (running kernel: 4.15.18-12-pve)" . Short description: a ping to the machine is still working even after shutting it down, but "ssh" is not...