Recent content by fabian

  1. fabian

    [SOLVED] CEPH Key Migration now "Not a proper rbd authentication file error"

    you need to upgrade the PVE packages, not just the Ceph packages.. most likely you have not configured your APT repositories correctly.
  2. fabian

    ProxMox 8 to 9 upgrade "You are attempting to remove the meta-package 'proxmox-ve'!"

    the ceph squid 19.2.6 packages are already on enterprise for trixie. bookworm/PVE 8.x is EOL
  3. fabian

    Help - Snapshot restore fails with short vma error

    please provide logs and details about your storage setup..
  4. fabian

    Opt-in Linux 7.0 Kernel for Proxmox VE 9 available

    if this is an option for you, test-booting the 7.2.4, 7.2.5 and 7.2.6 kernels (e.g. from https://kernel.ubuntu.com/mainline/) would be great to narrow it down.
  5. fabian

    losing dirty-bitmaps during Live Migration

    please provide the configs: - /etc/pve/storage.cfg - VM config as well as logs: - any tasks logs concerning the VM since it was started on the source - the migration and start task logs if you can easily reproduce it with a test VM, you could also run the following on the source node before...
  6. fabian

    [SOLVED] Root on encrypted ZFS boot issue suddenly

    https://pve.proxmox.com/pve-docs/pve-admin-guide.html#sysboot_edit_kernel_cmdline /etc/kernel/cmdline is used by systemd(-boot) and related tools. Grub does not read it at all.
  7. fabian

    data corruption on shared-lvm

    we already have previous reports about HPE MSA (and Dell) appliances misbehaving in exactly this fashion - they advertise support for zeroing unmap, but only do it when the request matches some conditions, and simply ignore the zeroing part otherwise...
  8. fabian

    Task after backup

    on the PBS side? now. on the PVE side? yes - there's vzdump hook scripts: https://pve.proxmox.com/pve-docs/pve-admin-guide.html#_hook_scripts
  9. fabian

    data corruption on shared-lvm

    compare the files and see where they differ (e.g., by running them through hexdump and comparing the dumps). try copying once more with `cp --sparse=never` and report back whether that copy is okay.
  10. fabian

    [SOLVED] Unable to start VM with Hookscript

    is the "shebang" (first line) of the script correct? could you maybe post it?
  11. fabian

    Password rules for @pve realm

    see https://bugzilla.proxmox.com/show_bug.cgi?id=5756 for some previous discussion
  12. fabian

    [SOLVED] Unable to start VM with Hookscript

    did you mark the script as executable?
  13. fabian

    [SOLVED] Root on encrypted ZFS boot issue suddenly

    I would recommend the following (on ThreadReaper) 1. remove the systemd-boot package 2. fill in /etc/default/grub using the one from the working node, but adapt "GRUB_CMDLINE_LINUX_DEFAULT" to get the correct kernel cmdline 3. clear out /etc/kernel/proxmox-boot-uuids 4. reformat your ESPs...
  14. fabian

    GRUB "no server is specified" / can't boot after extending pve/root LV onto second disk — bug ruled out

    you could also do what proxmox-boot-tool does and put the grub stage2, kernel and initrd on the ESP - grub only needs to read from the ESP then, and the kernel takes over before LVM is involved at all.
  15. fabian

    [SOLVED] Root on encrypted ZFS boot issue suddenly

    the output on ThreadReaper sounds very wrong - it states both grub and systemd-boot are installed on the ESPs, yet there is no Grub config file? could you please post "apt list --installed | grep -e systemd -e grub"?