[SOLVED] Windows Server 2012 R2 VM not starting after PVE upgrade 6 to 7


Apr 28, 2018
Hello together!

After upgrading my Proxmox from 6 to 7 today, I am facing strange problems. Some VMs are freezing after some hours (currently investigating that, don't know why, when looking into console it gives me "VM ... qmp command 'set_password' failed - unable to connect to VM ... qmp socket - timeout after 31 retries" error)

But the biggest problem is one Windows Server 2012 R2 instance, which won't start after upgrading. Loading the fix from here: https://forum.proxmox.com/threads/w...-patch-inside-see-53.84915/page-2#post-373380 did work, but I think this can't be a solution, as this package is overwritten with every update. Also changed the "Machine" setting to version 5.1, which did not work. In addition, processor is set to "Host".

When clicking "Start", the VM boots up, shows the Windows logo and the loading dots, after that the output goes blank and Console does not open (with error above).

Any advice what to do here? Thanks in advance!

proxmox-ve: 7.1-1 (running kernel: 5.13.19-1-pve) pve-manager: 7.1-6 (running version: 7.1-6/4e61e21c) pve-kernel-5.13: 7.1-4 pve-kernel-helper: 7.1-4 pve-kernel-5.4: 6.4-7 pve-kernel-5.13.19-1-pve: 5.13.19-2 pve-kernel-5.4.143-1-pve: 5.4.143-1 pve-kernel-5.4.128-1-pve: 5.4.128-2 ceph-fuse: 14.2.21-1 corosync: 3.1.5-pve2 criu: 3.15-1+pve-1 glusterfs-client: 9.2-1 ifupdown: not correctly installed ifupdown2: 3.1.0-1+pmx3 ksmtuned: 4.20150326 libjs-extjs: 7.0.0-1 libknet1: 1.22-pve2 libproxmox-acme-perl: 1.4.0 libproxmox-backup-qemu0: 1.2.0-1 libpve-access-control: 7.1-4 libpve-apiclient-perl: 3.2-1 libpve-common-perl: 7.0-14 libpve-guest-common-perl: 4.0-3 libpve-http-server-perl: 4.0-3 libpve-storage-perl: 7.0-15 libqb0: 1.0.5-1 libspice-server1: 0.14.3-2.1 lvm2: 2.03.11-2.1 lxc-pve: 4.0.9-4 lxcfs: 4.0.8-pve2 novnc-pve: 1.2.0-3 proxmox-backup-client: 2.1.1-1 proxmox-backup-file-restore: 2.1.1-1 proxmox-mini-journalreader: 1.2-1 proxmox-widget-toolkit: 3.4-3 pve-cluster: 7.1-2 pve-container: 4.1-2 pve-docs: 7.1-2 pve-edk2-firmware: 3.20210831-2 pve-firewall: 4.2-5 pve-firmware: 3.3-3 pve-ha-manager: 3.3-1 pve-i18n: 2.6-2 pve-qemu-kvm: 6.1.0-2 pve-xtermjs: 4.12.0-1 qemu-server: 7.1-4 smartmontools: 7.2-pve2 spiceterm: 3.2-2 swtpm: 0.7.0~rc1+2 vncterm: 1.7-1

12 x AMD Ryzen 5 3600 6-Core Processor (1 Socket)
Last edited:
Please update to latest kernel (pve-kernel-5.13.19-1-pve: 5.13.19-3) and try again.

And post your VM config:

> qm config VMID
  • Like
Reactions: Luki20
Please update to latest kernel (pve-kernel-5.13.19-1-pve: 5.13.19-3) and try again.
Upgrade running, thanks for the hint.

And post your VM config:

> qm config VMID
agent: 0
bootdisk: sata0
cores: 6
cpu: host
ide0: none,media=cdrom
machine: pc-i440fx-5.1
memory: 16384
name: WIN-EXSRV01
net0: e1000=MACaddress,bridge=vmbr0
numa: 0
onboot: 1
ostype: win8
sata0: nvmestorage2:103/vm-103-disk-0.qcow2,size=250G
scsihw: virtio-scsi-pci
smbios1: uuid=fbb3fd37-e8d7-4a19-9792-48175e92c1d2
sockets: 1
startup: order=4,up=300
vmgenid: d1dfbdfd-62d4-437e-95f4-dfef0ef081e8
After reboot of your host, please test your VM again and report here.
  • Like
Reactions: Luki20
After reboot of your host, please test your VM again and report here.
The upgrade sorted the problem out for me. Thanks a lot! Is it recommended to still use version 5.1 in the "Machine"-setting?

And should the issue with the crashing VMs after some hours also be fixed with this?
Please test and report back.
Update to my problem: Windows Server VM crashed now, opening console does not work:

VM 103 qmp command 'set_password' failed - unable to connect to VM 103 qmp socket - timeout after 31 retries
TASK ERROR: Failed to run vncproxy.

Ping with no success -> VM seems to be down

"Summary" of VM in Proxmox GUI is also not loading:


Had to "hard-stop" the VM now from the GUI, which worked, and now it's booting up and running again (for the next few hours).
Last edited:
Please update your mainboard bios to latest version, is there an update available?
(We got reports that this can fix issues like this too)


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!