Windows Server 2012 R2 and 0x0000005D Error

mat02

New Member
Aug 28, 2013
7
1
3
Windows 8 and newer require NX flag to be present in CPU, so I guess kvm64 cpu type propagates this from host to VM (CoreInfo program on Windows 7 guest detected that this flag is missing).
 
  • Like
Reactions: 1 person

e100

Active Member
Nov 6, 2010
1,235
24
38
Columbus, Ohio
ulbuilder.wordpress.com
Sorry to revive this old thread but I just ran across this issue and wanted to share my solutions.

If I set my CPU type to SandyBridge (what the host has) the Win 2012 iso boots up ok and so does Win 2012.
If I leave CPU set to default and add this to the conf file the Win 2012 iso boots ok but I did not test this with running the installed Win 2012.
Code:
args: -cpu kvm64,+lahf_lm,+cx16
spirit, I remember some talk on pve-devel about adding a win8.1 option, was that accepted?
 

spirit

Famous Member
Apr 2, 2010
3,561
164
83
www.odiso.com
Sorry to revive this old thread but I just ran across this issue and wanted to share my solutions.

If I set my CPU type to SandyBridge (what the host has) the Win 2012 iso boots up ok and so does Win 2012.
If I leave CPU set to default and add this to the conf file the Win 2012 iso boots ok but I did not test this with running the installed Win 2012.
Code:
args: -cpu kvm64,+lahf_lm,+cx16
spirit, I remember some talk on pve-devel about adding a win8.1 option, was that accepted?
yes, the lahf_lm has been added to win8 ostype one month ago. (I'm not sure it's already in pve-no-subscription repository)
 

e100

Active Member
Nov 6, 2010
1,235
24
38
Columbus, Ohio
ulbuilder.wordpress.com

spirit

Famous Member
Apr 2, 2010
3,561
164
83
www.odiso.com
I was reading that qemu already had the cx16 flag:
http://pve.proxmox.com/pipermail/pve-devel/2013-October/009079.html

Was that cx16 flag added to the newer version?
The 2012 ISO would only boot when I added both flags, I tried both individually.
The patch add only lahf_lm to kvm64 cpu model
https://git.proxmox.com/?p=qemu-server.git;a=commit;h=4dc339e7b4d0f4aa1756263ec889104de182994d


cx16 is already enabled by default in kvm64

see qemu source here for default cpu flags:
http://git.qemu.org/?p=qemu.git;a=blob;f=target-i386/cpu.c;h=0eea8c7160b673e75d546cc5beeed0740d9ea910;hb=HEAD
 

chip1

New Member
Jan 20, 2014
5
0
1
I'm having trouble locating the exact spot where we edit this .conf file at? Is it here: etc/pve/qemu-server/<VM number>.conf

Anytime we try to access this folder we get a permission denied message. I was told the following from the Linux person that setup our environment

“They don’t have root passwords. Ubuntu and Debian follow the ‘best practices’ and disable logging in as root” These are underlying as the ProxMox is the actual operating system for the servers using one of these as the foundation."

I was also told that my user has full admin access so i'm not sure why I can't get into this folder.

Any help is greatly appreciated, Thank You!!
 

m.ardito

Active Member
Feb 17, 2010
1,473
12
38
Torino, Italy
it could also be that the cluster lost quorum (too few nodes working to take safe decisions) and /etc/pve is in read-only mode

you can check trying, as root:

#clustat

you should read

"Member Status: Quorate"

otherwise /etc/pve is "protected", ie: in read only mode.

in this case, you can temporarily (until reboot) regain quorum with

#pvecm expected <number>
where <number is the number of your current active node votes

see also the output of

#pvecm status

Marco
 

bigfishinnet

Member
Feb 2, 2010
47
0
6
I just to confirm I has some issue. Windows 2012 0x0000005D error trying to install on Proxmox 3.4 and 3.3.

I ENABLED No-Execute Memory Protection in BIOS and they installed fine. The machines were HP ML and DL series.

In fact using processor type kvm64 when the BIOS setting "No-Execute Memory Protection" was enabled it AUTOMATICALLY ADDED args : -cpu kvm64,+cx16 to the .conf file.

Stephen
 
Last edited:

spirit

Famous Member
Apr 2, 2010
3,561
164
83
www.odiso.com
it AUTOMATICALLY ADDED args : -cpu kvm64,+cx16 to the .conf file.
Hi, proxmox don't add theses args anywhere. You must have done it manually.
Anyway, they are not require to boot win2012r2.

Only +lahf was missing, and proxmox pass it to qemu command line at vm start since proxmox 3.2. (but nothing special is write in vm config)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!