Windows 2019 QEMU agent service missing after installation

Jan 23, 2020
10
1
3
44
I am trying to add a guest agent to Windows 2019 but after successful installation, there is no QEMU-GA service even installation is stating that it started it.

From PowerShell:
Get-Service QEMU-GA
Get-Service : Cannot find any service with service name 'QEMU-GA'.

Versions:
proxmox-ve: 6.1-2 (running kernel: 5.3.10-1-pve)
pve-manager: 6.1-7 (running version: 6.1-7/13e58d5e)
Guest agent: virtio-win-0.1.173
Windows 2019 standard (1809)
VirtIO Balloon and VirtIO Serial drivers installed
QEMU Guest Agent enabled in options
 

Moayad

Proxmox Staff Member
Staff member
Jan 2, 2020
50
0
6
Hi,


Are you sure you have installed qemu-ga-x64.msi without error?


Also check service QEMU Guest Agent in windows if running, or maybe you have missing something.


Please check the steps again because i have tried on my own Lab, everything was ok

resources:
- Qemu-guest-agent wiki:
https://pve.proxmox.com/wiki/Qemu-guest-agent
- Qemu-guest-agent youtube tutorial:
https://youtu.be/fn6iJzRQDkw
 
Jan 23, 2020
10
1
3
44
Hi,


Are you sure you have installed qemu-ga-x64.msi without error?


Also check service QEMU Guest Agent in windows if running, or maybe you have missing something.


Please check the steps again because i have tried on my own Lab, everything was ok

resources:
- Qemu-guest-agent wiki:
https://pve.proxmox.com/wiki/Qemu-guest-agent
- Qemu-guest-agent youtube tutorial:
https://youtu.be/fn6iJzRQDkw
2020-03-24 15_41_15-Window.png2020-03-24 15_40_39-Window.png2020-03-24 15_40_25-Window.png2020-03-24 15_40_09-Window.png2020-03-24 15_39_44-Window.png2020-03-24 15_39_04-Window.png

The last window from installation wizard is saying that it finished and there isn't any error mentioned so I am assuming that it went without errors.
I didn't try to add Ballooning service since I don't yet have the main QEMU service.
 

Moayad

Proxmox Staff Member
Staff member
Jan 2, 2020
50
0
6
Hi,

Works here - please try to remove the agent inside window and reinstall it again

Code:
C:\Program Files\Qemu-ga>qemu-ga.exe -s uninstall


C:\Program Files\Qemu-ga>qemu-ga.exe -s vss-unistall
if not work, post your VM config qm config <VMID> and OS info as well qm agent <VMID> get-osinfo
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!