Win10 im Nachhinein VirtIO-Treiber unterjubeln?

Dec 19, 2012
464
14
83
Hallo.
ich habe ein Win10 geklont und kann es nicht starten.
Die Fehlermeldung lautet "INACCESSIBLE BOOT DEVICE". Die Hardware-Einstellungen stehen auf virtIO; ich habe aber auch schon andere Controller ausprobiert.
Kann man dem Win10 auch im Nachhinein VirtIO-Treiber unterjubeln?
Wie geht ihr da vor?
Danke.
 
welchen Crontroller hat den die VM von der du geclont hast?
Normalerweise sollte das ja gleich sein wie bei der geclonten und auch normal starten dann,
hatte bisher keine Probleme bei geclonten VMs

Stell die geclonte so ein wie die orginale VM wenn du dann virtio hinzugügen willst am besten neu neue HDD hinzufügen mit dem Controller und dann den Treiber einbinden dann kannst später die HDD wieder entfernen und deine andere HDD auf Virtio umstellen
 
Ich habe das Windows auf einem anderen Weg geklont als sonst. Die VM lief bisher nicht unter Proxmox -- daher startet sie jetzt auch nicht richtig. Habe es nun bereits mit dem ISO versucht und die Reparaturmechanismen angeworfen ... aber da sieht man ja auch nicht, woran es scheitert. Vermutlich müssen die virtIO nachträglich ins System.
 
startet windows, wenn die boot disk als IDE angeschlossen wird?
 
ja, im Notfallmodus ... da habe ich nun auch bereits die virtIO-Treiber alle installiert -- bekomme aber dennoch weiter ein
"Incaccessible Boot Device" beim Start. Aber imerhin einen Schritt weiter...
 
Wenn mit IDE booten geht, dann sind folgende Schritte nötig:
  1. Zweite HDD dazugeben, virtio-scsi, treiber installieren von der 173 treibe iso.
  2. runterfahren und die boot HDD von IDE wieder auf SCSI (virtio-scsi) stellen, booten sollte gehen
Siehe auch: https://pve.proxmox.com/wiki/Windows_10_guest_best_practices
 
Ging leider nicht. Die Treiber der DVD sind alle über den Notfallmodus (und eine weitere hingefügte IDE-Platte) installiert -- aber beim Systemstart komme ich trotzdem mit den Startoptionen nur bis zu dem Punkt "System konnte nicht repariert werden". Danach ist immer Schluss.
 
Was war denn die Quelle, also von welcher Hardware wurde geklont? Und wie?
 
Ich habe gestern auch noch eine Win7 Maschine von ESXI zu Proxmox migriert. Dort fehlten auch die VirtIO Treiber. Die Maschine bootete aber noch im Rettungsmodus. Dort habe ich dann unter Treiber laden die VirtIO Treiber nachgeladen sodass er die Windows Installation finden konnte.

Dann in die Eingabeaufforderung und dort mit DSIM die fehlenden Treiber Windows untergejubelt. Das hat Prima funktioniert.

Code:
dism /image:e:\ /add-driver /driver:d:\vioscsi\w7\amd64\vioscsi.inf
--- bzw. ---
dism /image:e:\ /add-driver /driver:d:\viostor\w7\amd64\viostor.inf
 
Tja ... hätte ich das nur ein paar Tage eher gewusst. Ich hatte es die ganze Zeit mit dem Notfallmodus und "drvload" versucht -- hat aber nie funktioniert. In der Zwischenzeit habe ich das Windows nun neu installiert und direkt bei der Installation die virtIO-Treiber dazu gepackt.

(Was übrigens noch seltsam war: Wenn man von der virIO-CD das Setup (im Hauptordner der DVD) aufruft und alles in einem Rutsch installieren lassen will, geht das schief -- hier wurde in der Win10-VM dann gemeckert, dass irgendein Dienst nicht gestartet werden kann und das ganze Setup wurde wieder zurückgerollt. )
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!