Vorhandene NTFS mit Medien in PVE nutzen

Leon Gaultier

Active Member
Mar 14, 2019
548
54
28
42
Du hast bestimmt die Container ID nicht angepasst im Hook Skript.
Ich habe das nun voll automatisiert hin bekommen. Inklusive automatischen mount ans Verzeichnis.
 

Leon Gaultier

Active Member
Mar 14, 2019
548
54
28
42
Meine Container Konfig
Code:
lxc.cgroup.devices.allow: b 8:16 rwm
lxc.cgroup.devices.allow: b 8:17 rwm
lxc.autodev: 1
lxc.hook.autodev: /var/lib/lxc/205/mount-hook.sh
mp1: /dev/sdb1,mp=/mnt,backup=0
 

ioB_Newcomer

Member
Jan 23, 2020
30
2
8
35
mp1: /dev/sdb1,mp=/mnt,backup=0

Das fehlt bei mir noch. Das ist neu..

Wenn ich jetzt mehrere HDD's einbinde dann mp2 / mp3 usw ?

mp1: /dev/sdb1,mp=/mnt,backup=0
mp2: /dev/sdc1,mp=/mnt,backup=0

Du hast bestimmt die Container ID nicht angepasst im Hook Skript.
Doch da habe ich 101 eingetragen.

Das steht in dem Script ..

Code:
#!/bin/sh
mknod -m 777 ${LXC_ROOTFS_MOUNT}/dev/sdb b 8 16
mknod -m 777 ${LXC_ROOTFS_MOUNT}/dev/sdb1 b 8 17
Oder muss ich hier noch die ID rein ?

ich habe aber glaube chmod vergessen ich teste mal eben.
 

Leon Gaultier

Active Member
Mar 14, 2019
548
54
28
42
Ja genau. Dann musst mp1 mp2 und so machen.
Ich kopiere gerade meine ganze Medienfiles über USB3. Ist Sau schnell.

Hast Du das Script ausführbar gemacht. chmod Befehl.
 

ioB_Newcomer

Member
Jan 23, 2020
30
2
8
35
Eben probiert gleiche Problem. Das habe ich nun auch noch in die conf erstellt .

Code:
mp1: /dev/sdb1,mp=/mnt,backup=0
Bringt auch nichts. Wie ich es hasse, wenn man so verloren vor dem Bildschirm sitzt. Wir haben doch alles so gemacht. Bei dir gehts bei mir mal wieder nicht.
 

Leon Gaultier

Active Member
Mar 14, 2019
548
54
28
42
Ich habe eine Theorie wie so der Container mit der automatischen Einbindung des Laufwerks nicht startet. Es liegt am read only von NTFS. Der lxc wird versuchen den Container mit read write laufwerken zu starten.
Ich schau mal wegen den alternativen NTFS driver. Heißst glaube ng-ntfs oder so.
 

Leon Gaultier

Active Member
Mar 14, 2019
548
54
28
42
ok heißt ntfs-3g

also bitte einmal auf dem Host System

apt-get install ntfs-3g

Danach den Container beenden und erstmal auf dem Host versuchen die Platte rw zu mounten.

mkdir /mnt/test

mount /dev/sdb1 /mnt/test

touch /mnt/test/test.txt

wenn das klappt dann wieder unmounten und den Container starten. Dann im Container das selbe machen und schauen ob es geht. wenn ja dann die Zeile in die Konfig für das automatische einbinden..
 
  • Like
Reactions: ioB_Newcomer

ioB_Newcomer

Member
Jan 23, 2020
30
2
8
35
Das Versuche ich noch, danach schmeiß ich glaub hin und geht einfach auf ein Debian und ohne proxmox. Dort hab ich es wenigstens hin bekommen. So macht es dann auch keinen Sinn, wenn ich noch nicht mal ne HDD in nen Container bekomme.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!