VM's on proxmox won't shutdown?

Discussion in 'Proxmox VE: Installation and configuration' started by RodinM, Jun 15, 2012.

  1. RodinM

    RodinM Member

    Joined:
    Aug 1, 2011
    Messages:
    69
    Likes Received:
    0
    Hi, I have some VM's installed on three nodes with Proxmox VE 2.1. The problem is that the VM's won't shutdown when I click the button "shutdown" in the main interface. I would say it didn't worked in proxmox ve 1.9 as well without opening the console window of the VM. But the VM DOES shutdown when I open the Console window of the VM and then press the button "shutdown" inside the console window.
    Is it normal?
     
  2. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    13,159
    Likes Received:
    352
    the "shutdown" button sends just an ACPI shutdown to the VM guest. If your guest does not accepts anonymous acpi shutdowns it does not work. search the forum, you will find a lot of such posts and solutions. if you cannot find something, tell details about your VM guests.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. RodinM

    RodinM Member

    Joined:
    Aug 1, 2011
    Messages:
    69
    Likes Received:
    0
    I stress on the fact, that the VM shuts down correct (these are mainly Windows guests) when I press the button on top of the VM console window (where the buttons Start Shutdown SendKey Reset Suspend are placed). So the ACPI signal sent to the VM works fine. I don't try to shutdown the windows guest from inside the guest itself. I repeat: the shutdown button DOES work but it works only when the console window of the guest is opened. When I simply choose the VM in the VM list at the left and press the "shutdown" button in the main interface of the proxmox, the VM won't shutdown, it just keeps running.
     
  4. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    13,159
    Likes Received:
    352
    works here. tested with win7.

    what task log do you get? (see the "tasks" on the bottom of the main interface).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    13,159
    Likes Received:
    352
    I see the issue for Win2008r2 server. using the VM console it shutdowns. using the main windows button, I got:

    TASK ERROR: VM quit/powerdown failed - got timeout
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. RodinM

    RodinM Member

    Joined:
    Aug 1, 2011
    Messages:
    69
    Likes Received:
    0
    Using the VM Console I can shutdown any machine (I have win2003 win7 win2008 win2008r2 and some debian guests). In some windows guests i had to set up in the security policy that the machine may be shutdown without being logged on. By the way the message "TASK ERROR: VM quit/powerdown failed - got timeout" can sometimes appear when shutting down the VM guests using the console window. I noticed it happens when a machine is heavy loaded.
    I now tried to shutdown a win7 guest using the main window. The same result:
    TASK ERROR: VM quit/powerdown failed - got timeout
    In short: I can't shutdown any of my machines using the main proxmox window. This is very inconvenient because I have to open each VM's console and press a shutdown button in the console, then close the console window and go to the next VM.
     
  7. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    13,159
    Likes Received:
    352
    as it works here it hard to debug. are you sure that it does not work with a plain win7 (do not add it to ADS, just test with plain iso install)?

    also Debian KVM guests works here without problems, as long as acpid is installed (aptitude install acpid).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. RodinM

    RodinM Member

    Joined:
    Aug 1, 2011
    Messages:
    69
    Likes Received:
    0
    Hmm... I think if it were up to the missing acpid packet debian guests wouldn't shut down at all regardless of where we press the "shutdown" button...Or am I wrong?
     
  9. RodinM

    RodinM Member

    Joined:
    Aug 1, 2011
    Messages:
    69
    Likes Received:
    0
    Yes. It was right. After I installed the acpid packet on a debian guest it shuts down correctly even from the main window without having to open the VM console window.
    But the question with the windows guests still remains. I already set up the security policy in windows guests that they may be shutdown without anybody being logged on. May be I missed something else?
     
  10. spirit

    spirit Well-Known Member
    Proxmox VE Subscriber

    Joined:
    Apr 2, 2010
    Messages:
    3,196
    Likes Received:
    110
    try to edit the regkey

    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\Shutdownwithoutlogon

    0=disabled
    1=enabled
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. madpilot

    madpilot New Member

    Joined:
    Sep 3, 2011
    Messages:
    2
    Likes Received:
    0
    I too have this problem. Tried the key change but it does not help.
    I am using 2.1 with all updates. All the windoze vm's on our system have the same issue. Currently using winxp, win2k3 and win2k8r2.

    Click shutdown, get: TASK ERROR: VM quit/powerdown failed - got timeout

    Click shutdown with console open (but not logged in) and it works as advertised, regardless of the suggested registry key.

    All linux vm's with acpid installed shutdown correctly.
     
  12. ivan901

    ivan901 New Member

    Joined:
    Jun 27, 2012
    Messages:
    8
    Likes Received:
    0
  13. ivan901

    ivan901 New Member

    Joined:
    Jun 27, 2012
    Messages:
    8
    Likes Received:
    0
    I answer myself:
    Solution is to disable messages when shutting down:
    Open gpedit.msc
    Go to Local Computer Policy->Computer Configuration->Administrative Templates->System
    Select Display Shutdown Event Tracker and disable it.
    Now it works.
    Thanks anyway.
     
  14. RodinM

    RodinM Member

    Joined:
    Aug 1, 2011
    Messages:
    69
    Likes Received:
    0
    Yes, it works!
    ivan901, you are the best! :)
    So that means, windows xp guest should shutdown out of the box because this option is off by default for windows xp.
    Seems like a collision (bug?) which was never noticed by MS company.
     
  15. giner

    giner Member

    Joined:
    Oct 14, 2009
    Messages:
    239
    Likes Received:
    0
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. RodinM

    RodinM Member

    Joined:
    Aug 1, 2011
    Messages:
    69
    Likes Received:
    0
    This solution was already mentioned in some previous posts. It helped partly (with this setting the Windows VM can be shutdown from the console window using the "shutdown" button).
    What did help (in 70% cases) is the solution suggested by ivan901 in this post. With this setting the VM can be shutdown (but not always again) using the "shutdown" button in the main gui.
    What I mean is shown on 2 screens below
    Снимок экрана о&#1.jpg

    Снимок экрана о&#1.jpg

    The first screen shows when it works.
    The second option shows when it doesn't.
     
  17. giner

    giner Member

    Joined:
    Oct 14, 2009
    Messages:
    239
    Likes Received:
    0
    I have just installed Windows 2008 R2 SP1, so it's clear installation.
    1. It shuts down well if console is open (read as "monitor is on") and doesn't work if console is being closed for more than 10 minutes.
    2. If I just disalbe "automatic switching monitor off" than a virtual machine can be shutted down any time without opening the console so it can also be shutted down when backup works in "shutdown mode" or when the whole proxmox host goes down.
    No more changes necessary for Windows 2008 R2 SP1.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. RodinM

    RodinM Member

    Joined:
    Aug 1, 2011
    Messages:
    69
    Likes Received:
    0
    With Windows 2008R2 installation it seems really working. As for Windows 2003R2 installation it behaves very interesting.
    I did all the changes mentioned in this post. Now I press "Shutdown" button in the main gui without opening the VM console and wait 5 minutes. After I see that the VM is still running I open the VM console window, see again that the VM is still running, press "Send key" > "Ctrl-Alt-Del" and.... the VM immediately starts shutdown procedure without asking anything more. Looks very stupid.
     
  19. giner

    giner Member

    Joined:
    Oct 14, 2009
    Messages:
    239
    Likes Received:
    0
    That is because of screensaver.
    http://pve.proxmox.com/wiki/Windows_2003_guest_best_practices#Power_settings
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  20. mathx

    mathx Member

    Joined:
    Jan 15, 2014
    Messages:
    80
    Likes Received:
    1
    And how do you shutdown a VM that's stuck waiting for a TFTPboot/failed boot? doesnt the virt bios accept ACPI signals?

    TASK ERROR: VM quit/powerdown failed - got timeout
     
    carlosmora likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice