vmlinuz not found, you need to run kernel first

IsThisThingOn

Member
Nov 26, 2021
83
21
13
Seems like I somehow destroyed my Proxmox installation, hopefully someone can help me restore it :eek:
Today I ran all the latest updates, shutdown the system and did a BIOS update.

When it loads up GRUB, I see 3 different version to boot
Proxmox Virtual Environment GNU/Linux, with Linux 5.4.128-1-pve
Proxmox Virtual Environment GNU/Linux, with Linux 5.4.124-1-pve
Proxmox Virtual Environment GNU/Linux, with Linux 5.3.18-3-pve

Every one of them gives me the same error.

Loading Linux 5.4.128-1-pve...
error: file (vmlinuz-5.4.128-1-pve' not found.
Loading inital ramdisk ...
error: you need to load the kernel first.

Any idea how I can safe this installation?

The installation is on a nvme ZFS mirror.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!