VM Start Timeout

aarcane

Active Member
Jul 28, 2015
35
3
33
So some of my VMs take longer to start than others. Typically if I either pass in a PCIE device or use a lot of memory, but most frequently when I do both. Example output is below, but the key error is: failed: got timeout.
If I run the command manually, it always works out and loads eventually. The timeout is the bug. I've opened a ticket on the bug tracker. Kindly, if you've ever experienced this, go add a vote to the bug in the tracker system!

https://bugzilla.proxmox.com/show_bug.cgi?id=4013

qm start 100
start failed: command '/usr/bin/kvm -id 100 -name ingot -no-shutdown -chardev 'socket,id=qmp,path=/var/run/qemu-server/100.qmp,server=on,wait=off' -mon 'chardev=qmp,mode=control' -chardev 'socket,id=qmp-event,path=/var/run/qmeventd.sock,reconnect=5' -mon 'chardev=qmp-event,mode=control' -pidfile /var/run/qemu-server/100.pid -daemonize -smbios 'type=1,uuid=ad97603d-eaaf-4525-8dc0-64c98bde6242' -drive 'if=pflash,unit=0,format=raw,readonly=on,file=/usr/share/pve-edk2-firmware//OVMF_CODE.fd' -drive 'if=pflash,unit=1,format=raw,id=drive-efidisk0,size=131072,file=/dev/zvol/zfs-ssd/vm-100-disk-2' -global 'ICH9-LPC.acpi-pci-hotplug-with-bridge-support=off' -smp '4,sockets=1,cores=4,maxcpus=4' -nodefaults -boot 'menu=on,strict=on,reboot-timeout=1000,splash=/usr/share/qemu-server/bootsplash.jpg' -vnc 'unix:/var/run/qemu-server/100.vnc,password=on' -cpu kvm64,+aes,enforce,+kvm_pv_eoi,+kvm_pv_unhalt,+lahf_lm,+pcid,+sep -m 32768 -object 'memory-backend-ram,id=ram-node0,size=32768M' -numa 'node,nodeid=0,cpus=0-3,memdev=ram-node0' -object 'iothread,id=iothread-virtio1' -readconfig /usr/share/qemu-server/pve-q35-4.0.cfg -device 'vmgenid,guid=a5e19863-9125-439e-af0f-e8a49548ef6b' -device 'usb-tablet,id=tablet,bus=ehci.0,port=1' -device 'vfio-pci,host=0000:04:00.0,id=hostpci0,bus=ich9-pcie-port-1,addr=0x0' -device 'virtio-vga,id=vga,bus=pcie.0,addr=0x1' -chardev 'socket,path=/var/run/qemu-server/100.qga,server=on,wait=off,id=qga0' -device 'virtio-serial,id=qga0,bus=pci.0,addr=0x8' -device 'virtserialport,chardev=qga0,name=org.qemu.guest_agent.0' -iscsi 'initiator-name=iqn.1993-08.org.debian:01:859be10c0b7' -drive 'file=/dev/zvol/zfs-ssd/vm-100-disk-0,if=none,id=drive-virtio0,discard=on,format=raw,cache=none,aio=io_uring,detect-zeroes=unmap' -device 'virtio-blk-pci,drive=drive-virtio0,id=virtio0,bus=pci.0,addr=0xa,bootindex=100' -drive 'file=/dev/zvol/zfs-ssd/vm-100-disk-1,if=none,id=drive-virtio1,discard=on,format=raw,cache=none,aio=io_uring,detect-zeroes=unmap' -device 'virtio-blk-pci,drive=drive-virtio1,id=virtio1,bus=pci.0,addr=0xb,iothread=iothread-virtio1' -netdev 'type=tap,id=net0,ifname=tap100i0,script=/var/lib/qemu-server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown,vhost=on' -device 'virtio-net-pci,mac=A2:66:31:8A:1D:88,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=101' -machine 'type=q35+pve0'' failed: got timeout
 

Neobin

Famous Member
Apr 29, 2021
1,145
410
83
Typically if I either pass in a PCIE device or use a lot of memory, but most frequently when I do both. Example output is below, but the key error is: failed: got timeout.

Using hugepages (if supported by the hardware) for those VMs can prevent this and also should give you a better memory performance on top.

Under the VM Configuration page, under the "options" tab, add an option "VM Startup Timeout" that defaults to whatever the current global startup timeout is, but allows entering a value in seconds at least as high as 3600, and preferably with no limit.

Could be a nice to have feature/option anyway.
 

leesteken

Famous Member
May 31, 2020
2,666
579
118
When PCI(e) passthrough is used, all VM memory needs to be pinned into action host RAM. Sound like your system takes a long time to gather enough free memory when starting the VM. How much RAM does your Proxmox host system have?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!