Virtual machine login problems


Jun 26, 2021
I don't know if this is a bug or by design
I have several laptops that I use to log into Proxmox. I used one machine to install and set up all my VM's. I was successful at rebooting and logging back into all of them. If I use a different laptop to access my VM's I am not able to log in with the passwords I set up. If I go back to the original laptop I used my passwords work just fine and once i have started and logged inot my VM's then I can go to any of my machines and use the VM's console. My problem is that I spent days setting up my lab and I left my laptop in another states when I was traveling and wont have it back for several days, and I would rather not have to start all over. i am guessing this designed for securitty but there must be a way around this without resetting passwords?
i am guessing this designed for securitty but there must be a way around this without resetting passwords?
I don't think this is a Proxmox feature. You can login to the Proxmox web GUI from another laptop? Maybe this is a keyboard layout issue?
How did you setup the VMs to only allow logins from your unavailable laptop? Did you put them on a virtual bridge with a different IP subnet? What kind of VMs are they?How are you trying to login: their graphical desktop or remotely via SSH or RDP?
In addition to @leesteken's answer ... if you mean the PVE web gui login, please check the realm setting on the actual login screen. If you created PVE users, you have to set it to PVE Users and not PAM.
Definitely not a proxmox feature.
Throwing another idea, do they all have the same keyboard layout?
I honestly never considered the keyboard layout. I have noticed that the special characters are not working on my keyboard. I never considered the fact that keyboards may be read differently. I will check the keyboard layouts and report back. Thanks guys, I could never had made it as far as I have without your help. I appreciate it more then I can express.
And I just tried to login using the numbers instead of the shift function for special characters and it worked just fine. Any suggestions about how to fix the issue of the special characters not working? every key is correct except using shift to use special characters?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!