USB UPS not detected after update

sntms

New Member
Mar 8, 2022
3
0
1
28
Hi,

yesterday my Proxmox host did an update and after a reboot the driver "usbhid-ups" is no longer available. On the USB 001/003 (where I have my UPS connected) I have now loaded a virtual Keyboard/Mouse Driver and I can't see the UPS anymore.

Any ideas on how to fix this?
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
694
118
hi,

* which package versions are you currently using? pveversion -v

* when was the last reboot? uptime -p

* lsusb output might be interesting

* and also you can try running dmesg -w in a terminal and plugging the device out and back in, see if any new entries/errors show up in the output
 

sntms

New Member
Mar 8, 2022
3
0
1
28
Code:
root@proxlab:~# pveversion -v
proxmox-ve: 7.1-1 (running kernel: 5.13.19-2-pve)
pve-manager: 7.1-7 (running version: 7.1-7/df5740ad)


Code:
root@proxlab:~# uptime -p
up 1 day, 15 hours, 32 minutes

Code:
root@proxlab:~# lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0624:0249 Avocent Corp. Virtual Keyboard/Mouse
Bus 001 Device 003: ID 413c:a001 Dell Computer Corp. Hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Nothing new with dmesg -w
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
694
118
thanks for the outputs but can you please post the full output of:
* which package versions are you currently using? pveversion -v


Nothing new with dmesg -w
that's interesting... so it's not being detected at all?

could you also check dmesg | grep -i usb? any entries there might be interesting...

can you also tail syslog while plugging/unplugging? f.e. tail -n 0 -f /var/log/syslog

if it's not showing up anywhere i'd also check the cables :)
 

tetrazocine

New Member
Oct 14, 2022
3
1
3
Folks, understand this is an older post but just came across my UPS unable to connect after a proxmox update where there were no infrastructure changes.

Upon review I could see that the USB device in /dev changed from /dev/ttyXRUSB0 to /dev/ttyUSB0.

I could see this with dmesg -w and checked the /etc/apcupsd/apcupsd.conf file and updated the device name. Restarted the process and all working again.

I hope this helps others.

NB.
 

LeidenSpain

New Member
Sep 9, 2022
11
0
1
Spain
Hi,

I have this same problem (I created a thread about it), but I can't find the file you indicate: I don't have the /etc/apcupsd folder
I think that file is only for APC UPS

Regards
 
Last edited:

tetrazocine

New Member
Oct 14, 2022
3
1
3
Hello @LeidenSpain, you may need to investigate what iteration of apcupsd you have installed as it's likely the config file is elsewhere. Perhaps try as root (or sudo):

find / -name "apcupsd.conf" -print | more

Apologies if you have already done this, not trying to be condescending in any way.

Another option is to use a command flag when starting apcupsd; looking at the man page you could have this in your init script:

apcupsd -f /etc/apcupsd/apcupsd.conf

and create a new apcupsd.conf. In actual fact you should not need this flag if you have that config file in this location as it's the default and the process will look here upon starting.

Run a google search for apcupsd.conf and there are plenty of examples that come up.

NB.
 
  • Like
Reactions: LeidenSpain

tetrazocine

New Member
Oct 14, 2022
3
1
3
Hello @LeidenSpain, you may need to investigate what iteration of apcupsd you have installed as it's likely the config file is elsewhere. Perhaps try as root (or sudo):

find / -name "apcupsd.conf" -print | more

Apologies if you have already done this, not trying to be condescending in any way.

Another option is to use a command flag when starting apcupsd; looking at the man page you could have this in your init script:

apcupsd -f /etc/apcupsd/apcupsd.conf

and create a new apcupsd.conf. In actual fact you should not need this flag if you have that config file in this location as it's the default and the process will look here upon starting.

Run a google search for apcupsd.conf and there are plenty of examples that come up.

NB.
I just re-read your post and realised that you may not have an APC UPS, apologies. What are you using for your UPS communication with your server? There should be a config file of some sort and you just need to adjust the /dev/?? reference after you establish what the new device link is. You can identify this a few ways.

As per one of the helpful posts above, use dmesg -w while inserting (or removing) the UPS USB cable to see what device is used OR you can do an lsusb to show devices but in my situation it was not obvious as the device for my UPS is listed as "Exar Corp. XR21V1410 USB-UART IC" which is not really helpful.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!