upgrade to kernel 5.13.19-4-pve problems

kyriazis

Member
Oct 28, 2019
92
4
13
Austin, TX
Hello...

I did a package upgrade yesterday 2/6/22 (including kernel update to 5.13.19-4-pve) and it's consistently hanging about 20-30 minutes after boot. Symptoms include:
- unresponsive console, does not respond to Ctrl-Alt-Del or ACPI Shutdown.
- "qm list" hanging. Some VMs hanging. LXC containers OK.
- "ps auxww" hanging half way through
- system load going up, but can't figure out from what, due to hanging "ps"
- reboot hanging

Booting kernel 5.13.19-2-pve (previous update) brings back stable behavior.

Is this a known issue?

This is on a single non-clustered node with zfs boot and other zfs pools.

Package list attached

Thank you!

Code:
proxmox-ve: 7.1-1 (running kernel: 5.13.19-2-pve)
pve-manager: 7.1-10 (running version: 7.1-10/6ddebafe)
pve-kernel-helper: 7.1-9
pve-kernel-5.13: 7.1-7
pve-kernel-5.11: 7.0-10
pve-kernel-5.13.19-4-pve: 5.13.19-8
pve-kernel-5.13.19-2-pve: 5.13.19-4
pve-kernel-5.13.19-1-pve: 5.13.19-3
pve-kernel-5.11.22-7-pve: 5.11.22-12
pve-kernel-5.11.22-5-pve: 5.11.22-10
pve-kernel-5.11.22-4-pve: 5.11.22-9
ceph-fuse: 15.2.14-pve1
corosync: 3.1.5-pve2
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown2: 3.1.0-1+pmx3
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.22-pve2
libproxmox-acme-perl: 1.4.1
libproxmox-backup-qemu0: 1.2.0-1
libpve-access-control: 7.1-6
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.1-2
libpve-guest-common-perl: 4.0-3
libpve-http-server-perl: 4.1-1
libpve-storage-perl: 7.0-15
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 4.0.11-1
lxcfs: 4.0.11-pve1
novnc-pve: 1.3.0-1
proxmox-backup-client: 2.1.5-1
proxmox-backup-file-restore: 2.1.5-1
proxmox-mini-journalreader: 1.3-1
proxmox-widget-toolkit: 3.4-5
pve-cluster: 7.1-3
pve-container: 4.1-3
pve-docs: 7.1-2
pve-edk2-firmware: 3.20210831-2
pve-firewall: 4.2-5
pve-firmware: 3.3-4
pve-ha-manager: 3.3-3
pve-i18n: 2.6-2
pve-qemu-kvm: 6.1.1-1
pve-xtermjs: 4.16.0-1
qemu-server: 7.1-4
smartmontools: 7.2-1
spiceterm: 3.2-2
swtpm: 0.7.0~rc1+2
vncterm: 1.7-1
zfsutils-linux: 2.1.2-pve1
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,551
1,817
174
South Tyrol/Italy
shop.proxmox.com
I did a package upgrade yesterday 2/6/22 (including kernel update to 5.13.19-4-pve) and it's consistently hanging about 20-30 minutes after boot. Symptoms include:
- unresponsive console, does not respond to Ctrl-Alt-Del or ACPI Shutdown.
- "qm list" hanging. Some VMs hanging. LXC containers OK.
- "ps auxww" hanging half way through
- system load going up, but can't figure out from what, due to hanging "ps"
- reboot hanging

Booting kernel 5.13.19-2-pve (previous update) brings back stable behavior.

Is this a known issue?
FYI: We know of problems with 5.13.19-4-pve and are looking into it, there are other threads regarding this, e.g.
https://forum.proxmox.com/threads/l...emu-pcie-sharing-works-with-5-13-19-3.104252/
 
  • Like
Reactions: kyriazis

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!