[SOLVED] upgrade issue from 5.4 to 6

ilia987

Active Member
Sep 9, 2019
270
13
38
36
i have done an upgrade on my cluster from 5.4 to 6,
but it failed on one of the nodes
currently the cluster is up and running, and i

zfs-initramfs : Depends: zfsutils-linux (>= 0.8.2-pve1) but 0.7.13-pve1~bpo2 is installed
zfs-zed : Depends: zfsutils-linux (>= 0.8.2-pve1) but 0.7.13-pve1~bpo2 is installed

any idea what i can do ?
 
please post the output of:
* `pveversion -v`
* `apt update`
* `apt full-upgrade`
 
please post the output of:
* `pveversion -v`
* `apt update`
* `apt full-upgrade`

pveversion -v
Bash:
pveversion -v
proxmox-ve: 6.0-2 (running kernel: 5.0.21-3-pve)
pve-manager: 6.0-9 (running version: 6.0-9/508dcee0)
pve-kernel-5.0: 6.0-9
pve-kernel-helper: 6.0-9
pve-kernel-4.15: 5.4-9
pve-kernel-5.0.21-3-pve: 5.0.21-7
pve-kernel-4.15.18-21-pve: 4.15.18-48
pve-kernel-4.15.18-20-pve: 4.15.18-46
pve-kernel-4.15.18-9-pve: 4.15.18-30
pve-kernel-4.15.18-1-pve: 4.15.18-19
pve-kernel-4.4.35-1-pve: 4.4.35-76
pve-kernel-4.4.19-1-pve: 4.4.19-66
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.2-pve4
criu: 3.11-3
glusterfs-client: 5.5-3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.13-pve1
libpve-access-control: 6.0-2
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-5
libpve-guest-common-perl: 3.0-1
libpve-http-server-perl: 3.0-3
libpve-storage-perl: 6.0-9
libqb0: 1.0.5-1
lvm2: 2.03.02-pve3
lxc-pve: 3.1.0-65
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.0-8
pve-cluster: 6.0-7
pve-container: 3.0-7
pve-docs: 6.0-7
pve-edk2-firmware: 2.20190614-1
pve-firewall: 4.0-7
pve-firmware: 3.0-2
pve-ha-manager: 3.0-2
pve-i18n: 2.0-3
pve-qemu-kvm: 4.0.0-7
pve-xtermjs: 3.13.2-1
qemu-server: 6.0-9
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.7.13-pve1~bpo2

apt update
Bash:
Hit:1 http://repo.pbis.beyondtrust.com/apt pbiso InRelease
Hit:2 http://ftp.debian.org/debian buster InRelease                                           
Hit:3 http://security.debian.org buster/updates InRelease                                         
Hit:4 http://download.proxmox.com/debian/corosync-3 stretch InRelease
Hit:5 http://download.proxmox.com/debian/pve buster InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
apt full-upgrade
Bash:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 zfs-initramfs : Depends: zfsutils-linux (>= 0.8.2-pve1) but 0.7.13-pve1~bpo2 is installed
 zfs-zed : Depends: zfsutils-linux (>= 0.8.2-pve1) but 0.7.13-pve1~bpo2 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
 
hmm - `apt update` output looks clean...
in any case - you should consider removing the corosync-3 repository (since you've upgraded to buster)

What's the output of 'apt --fix-broken install' ?
 
hmm - `apt update` output looks clean...
in any case - you should consider removing the corosync-3 repository (since you've upgraded to buster)

What's the output of 'apt --fix-broken install' ?
corosync-3 removed.

apt --fix-broken install
Bash:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  zfsutils-linux
Suggested packages:
  nfs-kernel-server samba-common-bin
The following packages will be upgraded:
  zfsutils-linux
1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
3 not fully installed or removed.
Need to get 0 B/355 kB of archives.
After this operation, 160 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Reading changelogs... Done
(Reading database ... 164920 files and directories currently installed.)
Preparing to unpack .../zfsutils-linux_0.8.2-pve1_amd64.deb ...
Unpacking zfsutils-linux (0.8.2-pve1) over (0.7.13-pve1~bpo2) ...
dpkg: error processing archive /var/cache/apt/archives/zfsutils-linux_0.8.2-pve1_amd64.deb (--unpack):
 trying to overwrite '/usr/share/man/man5/spl-module-parameters.5.gz', which is also in package spl-dkms 0.7.12-2
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/zfsutils-linux_0.8.2-pve1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
dpkg: error processing archive /var/cache/apt/archives/zfsutils-linux_0.8.2-pve1_amd64.deb (--unpack): trying to overwrite '/usr/share/man/man5/spl-module-parameters.5.gz', which is also in package spl-dkms 0.7.12-2
seems the system somehow installed the dkms packages from debian upstream. (PVE does not ship the dkms packages)

Try removing zfs-dkms and spl-dkms - and run apt install -f afterwards
 
  • Like
Reactions: ilia987
seems the system somehow installed the dkms packages from debian upstream. (PVE does not ship the dkms packages)

Try removing zfs-dkms and spl-dkms - and run apt install -f afterwards

thanks, it worked
i removed zfs-dkms spl-dkms zfsutils-linux zfs-initramfs zfs-zed zfsutils
and then installed zfsutils
now all seems stable. (trying to reboot the server to make sure all is working)
 
  • Like
Reactions: jerry
consider readding zfs-zed, zfs-initramfs as well
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!