Upgrade Cluster Corosync - Ignore Script ?

Oct 10, 2021
7
0
1
42
Currently running 4 node Promox cluster 5.4-15 with Ceph and trying to upgrade to Proxmox 6 and then hopefully Proxmox 7.

I have followed all the instructions documented on your site including https://pve.proxmox.com/wiki/Upgrade_from_5.x_to_6.0#Cluster:_always_upgrade_to_Corosync_3_first

The problem now is that Corosync 3 is running and in quorate but when I run your checker script pve5to6 i still get x1 fail:

Checking totem settings..
FAIL: Corosync transport explicitly set to 'udpu' instead of implicit default!
PASS: Corosync encryption and authentication enabled.

INFO: run 'pvecm status' to get detailed cluster status.

The quorum is healty and i can see in syslog that KNET is connected.

Dec 3 22:08:40 vm02 corosync[2240]: [TOTEM ] kronosnet crypto initialized: aes256/sha256
Dec 3 22:08:40 vm02 corosync[2240]: [TOTEM ] totemknet initialized
Dec 3 22:08:40 vm02 corosync[2240]: [KNET ] common: crypto_nss.so has been loaded from /usr/lib/x86_64-linux-gnu/kronosnet/crypto_nss.so
Dec 3 22:08:40 vm02 corosync[2240]: [SERV ] Service engine loaded: corosync configuration map access [0]
Dec 3 22:08:40 vm02 corosync[2240]: [QB ] server name: cmap
Dec 3 22:08:40 vm02 corosync[2240]: [SERV ] Service engine loaded: corosync configuration service [1]

My Quorate from pvecm status
Quorum information
------------------
Date: Mon Dec 6 09:57:10 2021
Quorum provider: corosync_votequorum
Nodes: 4
Node ID: 0x00000003
Ring ID: 1.58
Quorate: Yes

Votequorum information
----------------------
Expected votes: 4
Highest expected: 4
Total votes: 4
Quorum: 3
Flags: Quorate

Membership information
----------------------
Nodeid Votes Name

So....Should i ignore this error on the checkscript pve5to6 and continue to upgrade ?
 
Last edited:
Oct 10, 2021
7
0
1
42
Hi,

Please find the outputs below:

pveversion -v
proxmox-ve: 5.4-2 (running kernel: 4.15.18-30-pve)
pve-manager: 5.4-15 (running version: 5.4-15/d0ec33c6)
pve-kernel-4.15: 5.4-19
pve-kernel-4.15.18-30-pve: 4.15.18-58
pve-kernel-4.15.18-10-pve: 4.15.18-32
ceph: 12.2.13-pve1~bpo9
corosync: 3.0.4-pve1~bpo9
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1+deb9u1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-12
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-56
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-14
libpve-storage-perl: 5.0-44
libqb0: 1.0.5-1~bpo9+2
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-7
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
openvswitch-switch: 2.7.0-3
proxmox-widget-toolkit: 1.0-28
pve-cluster: 5.0-38
pve-container: 2.0-42
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-22
pve-firmware: 2.0-7
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 3.0.1-4
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-56
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2

corosync.conf

logging {
debug: off
to_syslog: yes
}

nodelist {
node {
name: node1
nodeid: 4
quorum_votes: 1
ring0_addr: node1ip
}
node {
name: node2
nodeid: 3
quorum_votes: 1
ring0_addr: node2ip
}
node {
name: node3
nodeid: 2
quorum_votes: 1
ring0_addr: node3ip
}
node {
name: node4
nodeid: 1
quorum_votes: 1
ring0_addr: node4ip
}
}

quorum {
provider: corosync_votequorum
}

totem {
cluster_name: myname
config_version: 7
interface {
bindnetaddr: 0.0.0.0
ringnumber: 0
}
ip_version: ipv4
secauth: on
transport: knet
version: 2
}
 
Oct 10, 2021
7
0
1
42
Hi Moayad,

I believe i did see that thread but wanted to check with the experts before attempting.

So for the avoidance of doubt.... you are saying "remove the transport line from the corosync configuration and continue with the upgrade ?"
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!