Updated Packages, Restarted, No Internet


New Member
Nov 10, 2023

I have had a Proxmox VE nodes running for months now without issues. Today I decided to update the packages (no-subscription repo) through the web interface and restart it. However, after doing so my node no longer connects to the internet. I did a lot of searching, and this seems to be a common issue when the /etc/network/interfaces file is misconfigured, but mine seems to be setup correctly.

Here is the output from ip a and cat /etc/network/interfaces:


Contents of /etc/resolv.conf:

search test

I tried adding auto enp0s31f6, setting enp0s31f6 static, setting both interfaces dhcp, setting enp0s31f6 static and dhcp and removing vmbr0, and connecting a USB Ethernet adapter and setting it as static. No matter what I try it will not connect to the local or outside network.

Also, the ifup and ifreload commands keep returning 'permission denied' even though I am root so I am rebooting the server every time I change something.

SOLVED: Most likely node got restarted while updating and some things got corrupt. We tried many things but running dpkg --configure -a after apt upgrade seemed to fix it.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!