unmet dependencies during proxmox installation

spayk

New Member
May 6, 2019
15
0
1
38
Hello,
so today I wanted to install proxmox on debian basen linux and after some tutorials when I try to paste the command:
Code:
apt install proxmox-ve postfix open-iscsi

I am getting this:
Code:
apt install proxmox-ve postfix open-iscsi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 proxmox-ve : Depends: pve-manager but it is not going to be installed
              Depends: pve-qemu-kvm but it is not going to be installed
              Depends: qemu-server but it is not going to be installed
              Depends: spiceterm but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
could anyone help?
 
Please check out the link, you need to have our repository active and updated.
https://pve.proxmox.com/pve-docs/chapter-pve-installation.html#_install_proxmox_ve_on_debian
Hello I have checked and tried to re-edit the repositories - updates and all going well but when trying to install by
Code:
apt-get install proxmox-ve
I am getting
Code:
apt-get install proxmox-ve
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 proxmox-ve : Depends: pve-manager but it is not going to be installed
              Depends: qemu-server but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

List of my repos:
Code:
cat sources.list

# deb cdrom:[Debian GNU/Linux 9 _Stretch_ - Official Snapshot amd64 LIVE/INSTALL Binary 20190327-12:32]/ stretch contrib main

#deb cdrom:[Debian GNU/Linux 9 _Stretch_ - Official Snapshot amd64 LIVE/INSTALL Binary 20190327-12:32]/ stretch contrib main


deb http://ftp.pl.debian.org/debian/ stretch main
deb-src http://ftp.pl.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main contrib
deb-src http://security.debian.org/debian-security stretch/updates main contrib

# stretch-updates, previously known as 'volatile'
deb http://ftp.pl.debian.org/debian/ stretch-updates main contrib
deb-src http://ftp.pl.debian.org/debian/ stretch-updates main contrib

deb http://ftp.debian.org/debian buster main contrib
deb http://ftp.debian.org/debian buster-updates main contrib

# security updates

deb http://security.debian.org buster/updates main
 
you mixed debian stretch with proxmox ve buster repo, this cannot work.

upgrade your debian to buster first and then add proxmox ve.
 
you mixed debian stretch with proxmox ve buster repo, this cannot work.

upgrade your debian to buster first and then add proxmox ve.
Upgraded to buster
Code:
lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 10 (buster)
Release:        10
Codename:       buster

trying to install, getting an error like that:
Code:
 apt install proxmox-ve postfix open-iscsi
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 mesa-utils : Depends: libglew2.1 (>= 1.12.0) but it is not going to be installed
 open-iscsi : Depends: libisns0 (>= 0.96-4~) but it is not going to be installed
 postfix : Depends: ssl-cert but it is not going to be installed
 proxmox-ve : Depends: pve-kernel-5.0 but it is not going to be installed
              Depends: pve-kernel-helper but it is not going to be installed
              Depends: pve-manager but it is not going to be installed
              Depends: pve-qemu-kvm but it is not going to be installed
              Depends: qemu-server but it is not going to be installed
              Depends: spiceterm but it is not going to be installed
              Depends: vncterm but it is not going to be installed
 python : PreDepends: python-minimal (= 2.7.13-2) but 2.7.16-1 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Should I remove the OS and upgrade it and then try again?
 
you have stretch repositories in your sources list.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!