With a Ceph cluster that has minimum client compatibility too new for krbd:
Booting a VM with a vTPM whose state is stored on rbd fails, even though PVE is configured to use librbd:
Shouldn't the TPM state be accessed through a userspace ceph client if krbd is disabled? swtpm doesn't have native librbd support but I'd think rbd-fuse would be the right way to go?
Code:
root@pve01:~# ceph osd get-require-min-compat-client
squid
Booting a VM with a vTPM whose state is stored on rbd fails, even though PVE is configured to use librbd:
Code:
Oct 06 17:23:47 pve03 kernel: libceph: mon2 (2)10.188.0.3:3300 session established
Oct 06 17:23:47 pve03 kernel: libceph: RADOS feature set mismatch: server's required > my supported 0x2f018fb87aa4aafe, missing 0x4000000000
Oct 06 17:23:47 pve03 kernel: libceph: mon2 (2)10.188.0.3:3300 missing required protocol features
Oct 06 17:23:47 pve03 kernel: libceph: mon2 (2)10.188.0.3:3300 session lost, hunting for new mon
Shouldn't the TPM state be accessed through a userspace ceph client if krbd is disabled? swtpm doesn't have native librbd support but I'd think rbd-fuse would be the right way to go?