1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[SOLVED] Unable to shutdown Windows 7 32-bit guest

Discussion in 'Proxmox VE: Installation and configuration' started by cosmos, Feb 27, 2014.

  1. cosmos

    cosmos Member

    Joined:
    Apr 1, 2013
    Messages:
    62
    Likes Received:
    0
    I have created a Windows 7 32-bit VM, under proxmox 3.1:

    Code:
    ~# pveversion -v
    proxmox-ve-2.6.32: 3.1-114 (running kernel: 2.6.32-26-pve)
    pve-manager: 3.1-21 (running version: 3.1-21/93bf03d4)
    pve-kernel-2.6.32-26-pve: 2.6.32-114
    lvm2: 2.02.98-pve4
    clvm: 2.02.98-pve4
    corosync-pve: 1.4.5-1
    openais-pve: 1.1.4-3
    libqb0: 0.11.1-2
    redhat-cluster-pve: 3.2.0-2
    resource-agents-pve: 3.9.2-4
    fence-agents-pve: 4.0.0-2
    pve-cluster: 3.0-8
    qemu-server: 3.1-8
    pve-firmware: 1.0-23
    libpve-common-perl: 3.0-8
    libpve-access-control: 3.0-7
    libpve-storage-perl: 3.0-17
    pve-libspice-server1: 0.12.4-2
    vncterm: 1.1-4
    vzctl: 4.0-1pve4
    vzprocps: 2.0.11-2
    vzquota: 3.1-2
    pve-qemu-kvm: 1.4-17
    ksm-control-daemon: 1.1-1
    glusterfs-client: 3.4.1-1
    
    VM details:
    Code:
    ~# qm config  100
    balloon: 1024
    boot: cd
    bootdisk: virtio0
    cores: 2
    ide0: none,media=cdrom
    memory: 1536
    name: testmachine
    net0: virtio=XX:XX:0C:1F:XX:XX,bridge=vmbr1
    onboot: 1
    ostype: win7
    sockets: 1
    virtio0: images:vm-100-disk-1,cache=writethrough,size=60G
    
    For some reason shutdown fails:
    Code:
    Feb 27 14:26:10 pve qm[354397]: <root@pam> starting task UPID:pve-1:0005685E:04AB5D69:530F2EE2:qmshutdown:100:root@pam:
    Feb 27 14:26:10 pve qm[354398]: shutdown VM 100: UPID:pve-1:0005685E:04AB5D69:530F2EE2:qmshutdown:100:root@pam:
    [...]
    Feb 27 14:27:10 pve qm[354398]: VM quit/powerdown failed - got timeout
    Feb  27 14:27:10 pve qm[354397]: <root@pam> end task  UPID:pve-1:0005685E:04AB5D69:530F2EE2:qmshutdown:100:root@pam: VM  quit/powerdown failed - got timeout
    
    qm stop does work, but inevitably shuts down in an unclean fashion. Hence, not an option.
     
    #1 cosmos, Feb 27, 2014
    Last edited: Feb 28, 2014
  2. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    12,130
    Likes Received:
    218
    your windows VM needs to accept anonymous ACPI shutdown, configure this inside windows.

    and search the forum for similar threads.
     
  3. cosmos

    cosmos Member

    Joined:
    Apr 1, 2013
    Messages:
    62
    Likes Received:
    0
    TBH, I do not how to go about this. This is a Windows VM fresh install, on a fresh install of PVE 3.1. Followed the settings wizard closely. I just elected to use virtio, as outlined in your windows 7 best practices wiki page.

    I did search the forum, but found nothing conclusive. Just some pointers to include powerdown scripts, or include some reg keys. Also read and followed the Wiki notes for Windows 2008 guests (https://pve.proxmox.com/wiki/Windows_2008_guest_best_practices ), regarding a couple of changes that should be made, and applied them on my Windows 7 VM. No go.

    From the search around, I understand this this seems to be an old issue. That is not a problem. The main problem is that no clear solution exists for those encountering it, otherwise I'd see it in the Windows 7 best practices wiki page, or perhaps I'd find it clearly in the forum.

    Will keep searching, hopefully someone will step in with some more information on how to resolve this.
     
  4. cosmos

    cosmos Member

    Joined:
    Apr 1, 2013
    Messages:
    62
    Likes Received:
    0
    Somehow it works right now. It's a pity that I do not know what exactly fixed things here... For the record, I changed all the following:

    * make sure that in power options, pressing the power button shuts down the system
    * Disable the 'Shutdown Event Tracker'. This setting in Group Policy. If the server is part of a domain, you need to edit the group policy for the organizational unit with the server. If you're not using a domain, you can edit the local group policy. This can be accessed by doing the following: Start -> Run -> gpedit.msc -> ok -> open "Computer Configuration" then "Policy" then "Administrative Templates" then "System". In the right pane, double click on 'Display Shutdown Event Tracker' and select 'disable' and OK. To make sure the new group policy is applied. Go to Start -> run -> cmd -> ok and type in 'gpupdate /force' without the quotes. Now when you select shutdown, you won't be promoted with the box asking why you are shutting down the server.
    * Control Panel -> System and Security -> Power Options -> Edit Plan Settings -> Turn off the display: Never
     
    #4 cosmos, Feb 28, 2014
    Last edited: Feb 28, 2014
  5. fza

    fza New Member

    Joined:
    Apr 2, 2017
    Messages:
    1
    Likes Received:
    0
    @cosmos Rather old post, but thanks for the write up! Had the same problem on pve 5.0 with Windows 7 and Windows 2k12 guests (all 64 bit). Your steps fixed the shutdown problem.
     

Share This Page