Unable to install Proxmox VE 6.1 on zbox ci329nano

_the_

Member
Feb 28, 2020
7
0
21
40
Currently I am trying to install PVE on my ZBOX, but it always fails on the last step, configuring GRUB with
failed to prepare EFI boot using Grub on /dev/sda2: unable to install the EFI boot loader on /dev/sda

The console on (ctrl+alt+f2) does not show more informations about that error

Any hints here, how to correctly install the bootloader?

Thanks in advance
 
hi,

if the installer detects UEFI, then it will try to install EFI + systemd-boot
otherwise it will default to grub

maybe you can check the BIOS settings to see if you can enable/disable UEFI support and see if that changes anything
 
The BIOS shows me several options for UEFI
pure UEFI (default)
UEFI compatible
legacy

With pure it fails to install grub here. Also what I have seen SecureBoot was enabled.
It also fails with pure without SecureBoot with the same error.
Will keep you updated with the other BIOS options
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!