[SOLVED] Unable to execute shell commands


New Member
Jul 19, 2023
Apologies. If its a silly question. I am very new to Proxmox. Have been using to run instances of home assistance or some virtual machines.

I tried Proxmox 8 release on HP microserver and Dell mini pc. I managed to successfully log in to gui. However, the experience is little different. The updates takes forever to scan. Second most critical issue is that I can't execute shell commands. It's like nothing was entered. Previously and I checked with developers there is nothing thay has broken from their end.

For e.g. I am trying to execute

bash -c "$(wget -qLO - https://github.com/tteck/Proxmox/raw/main/vm/haos-vm.sh)"

This used to auto create a vm for home assistant. And now using this command does nothing for me.

I tried this with vProxmox 7 as well. On both system. Seems to be something i am missing
Blindly executing scripts sourced from the Internet is not a great security posture. You should simply download the script, examine it, then execute if you think its safe.

Troubleshooting bash script is usually done with "-x" option, or by modifying script with "set +x" command.
Given that script is not provided by PVE developers, you should post your question to the authors via github, ie in "issues".

Good luck

Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox
Thank you for replying. This is a very trusted script for home assistant. And before posting this here. I did post at the author github. He said the trouble is at my end.
For me the DNS settings was not the issue, it's running on my Pi-hole and the second DNS is Problem stays as long I need to update an LXC or install a new container. No problem settinag manually new VMs... driving me crazy, will search again for "how to debug bash script" and read some 5 pages per day until I'll get the problem solved.
I appreciate everyone's frustration. It is disappointing when things that should be working are not.

That said, I did advise in comment #2 to download and execute the script manually. The DNS issue would have become apparent, as "wget" would fail with an appropriate message. Or, since the "-q" option was used - it would exit without actual download, which again points to the specific direction to troubleshoot.

There is no correlation between running a bash script and functioning DNS. Unless there is something in the script that requires access to the Internet, there is no dependency on the DNS. It was not the bash script failure, but rather the "wget" before the bash script execution.

As much as we'd like to provide a solution - it is often impossible without the solution seeker doing at least minimal troubleshooting or providing factual information.

Good luck

Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox
Last edited:
  • Like
Reactions: paxmobile


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!