[SOLVED] Unable to Boot Guest from CentOS 7 .iso


New Member
Jul 3, 2017
I am running Proxmox 5.4-5.

I have created a VM and mounted its DVD to a CentOS-7-x86_64-Minimal-1810.iso image with the intention of install CentOS. When I power the VM, I see no signs of booting occurring in the Console. qm status yields simply "status: running".

The VM's hardware is as follows:
Memory: 2.00 GiB
Processors: 2 (1 socket, 2 cores)
BIOS: Default (SeaBIOS)
Display: Default
Machine: Default (i440fx)
SCSI Controller: VirtIO SCSI
CD/DVD Drive (ide2): local:iso/CentOS-7-x86_64-Minimal-1810.iso,media=cdrom
Hard Disk (scsi0): local-zfs:vm-8002-disk-0,size=16G
Network Device (net0): virtio=<REDACTED>,bridge=vmbr0,firewall=1

The relevant VM options are as follows:
OS Type: Linux 4.X/3.X/2.6 Kernel
Boot Order: CD-ROM, Disk 'scsi0'
Hotplug: Disk, Network, USB
ACPI Support: Yes
KVM Hardware Virtualization: Yes
Freeze CPU at startup: No
Use local time for RTC: no
RTC start date: now
SMBIOS settings (type 1): uuid=<REDACTED>
Qemu Agent: Enabled
Protection: No

Why might I be unable to boot this VM from the CentOS installation .iso?



it seems like you're matching the minimum system requirements.

i'm downloading the same iso to try and create a vm with the same settings as you did, and get back to you soon.

in the meantime, you can send me your `qm config VMID` output.
Thank you for getting back so quickly. The requested output is:

agent: 1
boot: dc
bootdisk: scsi0
cores: 2
ide2: local:iso/CentOS-7-x86_64-Minimal-1810.iso,media=cdrom
memory: 2048
name: centos-2
net0: virtio=<66:EA:7E:REDACTED>,bridge=vmbr0,firewall=1
numa: 0
ostype: l26
scsi0: local-zfs:vm-8002-disk-0,size=16G
scsihw: virtio-scsi-pci
smbios1: uuid=<REDACTED>sockets: 1
vmgenid: 3cab654d-b49f-44b5-a0e2-7ceee6dbb1d4
i just tried with the same settings (only difference is i'm using lvm-thin instead of zfs), and it booted up (i see the centos boot menu with options).

my config also matches yours, except the storage type.

what is the output of your `pveversion -v`?
pveversion -v yields the following:

proxmox-ve: 5.4-1 (running kernel: 4.15.18-13-pve)
pve-manager: 5.4-5 (running version: 5.4-5/c6fdb264)
pve-kernel-4.15: 5.4-1
pve-kernel-4.13: 5.2-2
pve-kernel-4.15.18-13-pve: 4.15.18-37
pve-kernel-4.15.18-10-pve: 4.15.18-32
pve-kernel-4.15.18-8-pve: 4.15.18-28
pve-kernel-4.15.18-4-pve: 4.15.18-23
pve-kernel-4.13.16-4-pve: 4.13.16-51
pve-kernel-4.13.16-2-pve: 4.13.16-48
pve-kernel-4.13.16-1-pve: 4.13.16-46
pve-kernel-4.13.13-6-pve: 4.13.13-42
pve-kernel-4.13.13-5-pve: 4.13.13-38
pve-kernel-4.13.13-4-pve: 4.13.13-35
pve-kernel-4.13.13-2-pve: 4.13.13-33
pve-kernel-4.13.8-3-pve: 4.13.8-30
pve-kernel-4.13.8-2-pve: 4.13.8-28
pve-kernel-4.13.4-1-pve: 4.13.4-26
pve-kernel-4.10.17-2-pve: 4.10.17-20
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-8
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-51
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-13
libpve-storage-perl: 5.0-41
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-3
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-26
pve-cluster: 5.0-36
pve-container: 2.0-37
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-20
pve-firmware: 2.0-6
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 2.12.1-3
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-50
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2
I upgraded as suggested. I am still unable to boot from the .iso.

I also detached the hard drive and re-created it (still 16 GB). (Side question: Do I now have an unused virtual drive lying around (from the detach) consuming 16 GB of space?) This left me still unable to reboot from the .iso.

Finally, I resized the disk to 32 GB. Still, not able to boot from the .iso.

Are there other things I might check or try???

Thank you again.
interesting. i think all that's left is a storage-based or a browser-based problem.

Side question: Do I now have an unused virtual drive lying around (from the detach) consuming 16 GB of space?

yes, if you haven't removed it. (detach/remove is different)

maybe you can check on your proxmox host if the vm is actually running?

ps aux | grep kvm

you should see entries like `/usr/bin/kvm -id VMID ...`. if you can see your vm there, then it means it's probably booting ok. if it's there, then it might be something with the browser. maybe you can try a different one, or change your connection method (spice or xterm.js for example)


i forgot to add, but maybe you can try setting up the disk on another kind of storage (lvm-thin worked for me)
Last edited:
ps aux | grep kvm confirms the VM is running.

SPICE and xterm.js are greyed out. I am unsure why.


Switching to Firefox 60.6.1 allowed me to see the display! (I had been using IE 11). Unsure why this is.

Thank you very much. Sure appreciate it!
you're welcome, glad the problem is solved!

you can mark this thread as [SOLVED] if you edit your first post.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!