[SOLVED] Unable to access internet on new host


New Member
Oct 17, 2023

I just installed proxmox on a second host today (pveh2), added it to a cluster, and tried to access the web on it but it's not working. I'm not sure if the fact that I added it to a cluster immediately after install proxmox is relevant.

$ curl ifcfg.me
curl: (6) Could not resolve host: ifcfg.me

$ apt update
...W: Failed to fetch http://ftp.us.debian.org/debian/dists/bookworm/InRelease  Temporary failure resolving 'ftp.us.debian.org'...

I have already compared /etc/network/interface and /etc/hosts, and the output of ip a on both machines. The second machine (pveh2) has all very similar configurations, except of course the hostname and the host IP.

Any ideas as to what I should try next?

root@pveh2:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master vmbr0 state UP group default qlen 1000
    link/ether 6c:2b:59:e2:81:34 brd ff:ff:ff:ff:ff:ff
    altname enp0s31f6
3: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 6c:2b:59:e2:81:34 brd ff:ff:ff:ff:ff:ff
    inet scope global vmbr0
       valid_lft forever preferred_lft forever
    inet6 fe80::6e2b:59ff:fee2:8134/64 scope link
       valid_lft forever preferred_lft forever

Code: localhost.localdomain localhost pveh2.teachers.local pveh2

# The following lines are desirable for IPv6 capable hosts

::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

root@pveh2:~# cat /etc/network/interfaces
auto lo
iface lo inet loopback

iface eno1 inet manual

auto vmbr0
iface vmbr0 inet static
        bridge-ports eno1
        bridge-stp off
        bridge-fd 0

By the way -- I know the host clock is out of sync on the second machine. I was hoping to connect it to the internet to fix that.
That was it, somehow nameserver was set to maybe because I installed proxmox with no connection?

Thanks for your insanely fast reply
  • Like
Reactions: bbgeek17


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!