UEFI Windows 10 32 bits ISO

eglyn

New Member
Aug 26, 2021
13
0
1
42
Hi,

I try to setup a Windows 10 32 bits with UEFI bios, but I can't boot on the iso.

I tried a Debian ISO, and it works...

So , I tried to manualy add the bootia32.efi in the OVMF menu, and it said that:

1649065641706.png

Any idea to setup a Windows 10 32 bits installation with UEFI ?

thx !
 

Hannes Laimer

Proxmox Staff Member
Staff member
Jul 27, 2020
442
59
33
23
Hey,

does the 64 bit version of Windows 10 work? Could you post pveversion -v?
 

eglyn

New Member
Aug 26, 2021
13
0
1
42
Yes Windows 10 64 iso boots :/
and Windows 10 32 bits iso boots on Seabios mode

Code:
proxmox-ve: 7.1-1 (running kernel: 5.13.19-1-pve)
pve-manager: 7.1-10 (running version: 7.1-10/6ddebafe)
pve-kernel-helper: 7.1-13
pve-kernel-5.13: 7.1-9
pve-kernel-5.13.19-6-pve: 5.13.19-14
pve-kernel-5.13.19-2-pve: 5.13.19-4
pve-kernel-5.13.19-1-pve: 5.13.19-3
ceph-fuse: 15.2.15-pve1
corosync: 3.1.5-pve2
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown2: 3.1.0-1+pmx3
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.22-pve2
libproxmox-acme-perl: 1.4.1
libproxmox-backup-qemu0: 1.2.0-1
libpve-access-control: 7.1-6
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.1-3
libpve-guest-common-perl: 4.1-1
libpve-http-server-perl: 4.1-1
libpve-storage-perl: 7.1-1
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 4.0.11-1
lxcfs: 4.0.11-pve1
novnc-pve: 1.3.0-2
proxmox-backup-client: 2.1.5-1
proxmox-backup-file-restore: 2.1.5-1
proxmox-mini-journalreader: 1.3-1
proxmox-widget-toolkit: 3.4-7
pve-cluster: 7.1-3
pve-container: 4.1-4
pve-docs: 7.1-2
pve-edk2-firmware: 3.20210831-2
pve-firewall: 4.2-5
pve-firmware: 3.3-6
pve-ha-manager: 3.3-3
pve-i18n: 2.6-2
pve-qemu-kvm: 6.1.1-2
pve-xtermjs: 4.16.0-1
qemu-server: 7.1-4
smartmontools: 7.2-pve2
spiceterm: 3.2-2
swtpm: 0.7.1~bpo11+1
vncterm: 1.7-1
zfsutils-linux: 2.1.2-pve1
 
Last edited:

Neobin

Active Member
Apr 29, 2021
681
218
43
Maybe try with disabled secure boot in the VMs UEFI.
Not tested, only an idea.
 

eglyn

New Member
Aug 26, 2021
13
0
1
42
Maybe try with disabled secure boot in the VMs UEFI.
Not tested, only an idea.

I need secure boot because of security policy of the network :/ (+ TPM, UEFI and Bitlocker active with TPM)

I try to install the same ISO on Vsphere with vTPM and EFI (and secure boot active), and it works, I think it is a issue with Proxmox :(
 

Hannes Laimer

Proxmox Staff Member
Staff member
Jul 27, 2020
442
59
33
23
For a 32-bit OS, you need a 32-bit UEFI (same for 64-bit). It should be possible to build OVMF with 32-bit support. However, since the use cases are so limited we do not support that. If I may ask, why do you need the 32-bit version of Windows? Everything that runs on 32-bit should also run on 64-bit.
 

eglyn

New Member
Aug 26, 2021
13
0
1
42
For a 32-bit OS, you need a 32-bit UEFI (same for 64-bit). It should be possible to build OVMF with 32-bit support. However, since the use cases are so limited we do not support that. If I may ask, why do you need the 32-bit version of Windows? Everything that runs on 32-bit should also run on 64-bit.

unfortunately I need 32 bits OS to run an old version of Windev 5, wich does not work on 64 bits OS :/
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!