[SOLVED] Ubuntu Bionic image stucks on boot

osexp2000

New Member
Dec 3, 2019
6
0
1
46
I have set up a KVM, configured its disk to use Ubuntu Bionic raw image
http://cloud-images-archive.ubuntu....181206/ubuntu-18.04-server-cloudimg-amd64.img

It always stucks on boot screen
1581663120278.png


I found that If I adjust KVM option and directly run the adjusted KVM command line, it works fine,
here is what I adjusted:


- remove the `-nodefaults` option
- change `-device 'VGA,id=vga,bus=pci.0,addr=0x2'`: `addr=0x2` => `addr=0x10` or whatever non-conflict value


Here is the original KVM command line:

Bash:
/usr/bin/kvm \
-id 9000 \
-name vm9000 \
-chardev 'socket,id=qmp,path=/var/run/qemu-server/9000.qmp,server,nowait' \
-mon 'chardev=qmp,mode=control' \
-chardev 'socket,id=qmp-event,path=/var/run/qmeventd.sock,reconnect=5' \
-mon 'chardev=qmp-event,mode=control' \
-pidfile /var/run/qemu-server/9000.pid \
-daemonize \
-smbios 'type=1,uuid=60e879a8-331e-495e-aa84-7de7901f5c05' \
-smp '1,sockets=1,cores=1,maxcpus=1' \
-nodefaults \
-boot 'menu=on,strict=on,reboot-timeout=1000,splash=/usr/share/qemu-server/bootsplash.jpg' \
-vnc unix:/var/run/qemu-server/9000.vnc,x509,password \
-cpu kvm64,+lahf_lm,+sep,+kvm_pv_unhalt,+kvm_pv_eoi,enforce \
-m 512 \
-device 'pci-bridge,id=pci.1,chassis_nr=1,bus=pci.0,addr=0x1e' \
-device 'pci-bridge,id=pci.2,chassis_nr=2,bus=pci.0,addr=0x1f' \
-device 'vmgenid,guid=e1f8586f-9bad-4208-ac94-530ae2338a34' \
-device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' \
-device 'usb-tablet,id=tablet,bus=uhci.0,port=1' \
-device 'VGA,id=vga,bus=pci.0,addr=0x2' \
-device 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' \
-iscsi 'initiator-name=iqn.1993-08.org.debian:01:9deee52ef73' \
-drive 'file=/var/lib/vz/images/9000/vm-9000-cloudinit.qcow2,if=none,id=drive-ide2,media=cdrom,aio=threads' \
-device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' \
-device 'ahci,id=ahci0,multifunction=on,bus=pci.0,addr=0x7' \
-drive 'file=/var/lib/vz/images/9000/vm-9000-disk-0.raw,if=none,id=drive-sata0,format=raw,cache=none,aio=native,detect-zeroes=on' \
-device 'ide-hd,bus=ahci0.0,drive=drive-sata0,id=sata0,bootindex=100' \
-machine 'type=pc'

Anyone know what is the reason?

My proxmox version is Virtual Environment 6.0-11 on Debian Buster.
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
5,823
391
103
My proxmox version is Virtual Environment 6.0-11 on Debian Buster.
Please update to the current version and look if the problem still exists.
 

osexp2000

New Member
Dec 3, 2019
6
0
1
46
@wolfgang, this issue happend in Proxmox 5, so I upgraded to latest Proxmox 6, still same issue, why do I need upgrade again?
I have pointed out that there is a workaround, just ask for the underline reason or better solution.

- remove the `-nodefaults` option
- change `-device 'VGA,id=vga,bus=pci.0,addr=0x2'`: `addr=0x2` => `addr=0x10` or whatever non-conflict value
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
4,584
428
103
31
Vienna
i'd suggest to simply change the virtual graphics card to something different, e.g. virtio
 
  • Like
Reactions: osexp2000

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
1,700
184
63
how can I close this thread?
marked solved for you.

you can do this next time by editing the thread prefix and choosing [SOLVED]
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!