strange qnetd ghost config file

de Thysebaert

Active Member
Mar 12, 2017
42
3
28
65
Hi,
In the past I use qnetd as quorum device when I run only 2 nodes.
For 3 years we have 3 nodes configured with corosync for the quorum and I regulary add or removes nodes to upgrade hardward and keep up to date for performance.

To verify my config and also prepare to migrate from v5 to v6 I ran some verifications and found that there are 4 expected votes as below (pvem status) and ran after also the pve5to6 script.
As I understand quorum provider is well corosync, but the config attemps 4 votes because there stay config for qnetd device ( INFO: configured votes - qdevice: 1) returned by pv5to6.
In /etc/pve I found the file corosync.qdev witch seam to be my old config for qnet device. I think that the fourth expected votes comes form that old config. I understand that when I add the third nodes and configure corosync as quorum provider that aI let this old config file there and that this file was replicated each time I add a new node.

the systemctl status corosync-qnetd command on each nodes return Unit corosync-qnetd.service could not be found.

May I just move this file to another place to retun to a normal situation for my 3 nodes with only corosync as provider ?

thx


pvecm status
Quorum information
------------------
Date: Mon Jul 5 22:33:47 2021
Quorum provider: corosync_votequorum
Nodes: 3
Node ID: 0x00000001
Ring ID: 3/59624
Quorate: Yes

Votequorum information
----------------------
Expected votes: 4
Highest expected: 4
Total votes: 3
Quorum: 3
Flags: Quorate

Membership information
----------------------
Nodeid Votes Name
0x00000003 1 172.16.0.4
0x00000004 1 172.16.0.6
0x00000001 1 172.16.0.7 (local)


pve5to6

Analzying quorum settings and state..
INFO: configured votes - nodes: 3
INFO: configured votes - qdevice: 1
INFO: current expected votes: 4
INFO: current total votes: 3
WARN: total votes < expected votes: 3/4!

pvecm nodes

Membership information
----------------------
Nodeid Votes Name
3 1 172.16.0.4
4 1 172.16.0.6
1 1 172.16.0.7 (local)
 

dylanw

Proxmox Retired Staff
Retired Staff
Jul 6, 2020
373
72
28
I can't find any reference to the file '/etc/pve/corosync.qdev' anywhere, and not sure it's something that was placed there by Proxmox VE. What is the contents of this file? Is there any mention of the qdevice in /etc/pve/corosync.conf? Have you tried running pvecm qdevice remove?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!