Storage - NFS Configuration, cannot see all NAS network shares

neilsonwheels

New Member
Jul 2, 2023
18
2
3
I'm trying to setup storage using a NAS network share. When I configure a new Proxmox Storage, I can only see one NAS share titled 'public'. I cannot see any others.
In other words, when I select the Export drop-down menu, I only see '/Public'.

I have other NAS shares including one named 'backups' that I want to use for backups. I've tried manually entering the path, but i get a permission error.

My 'public' share is configured on my NAS as read-only for 'everyone', so that makes sense why Proxmox can see that share. I enabled the same read-only permissions for 'everyone' on some other NAS shares, but they still don't appear in the Export drop-down.

I'm a bit baffled as to what I need to do. I've rebooted proxmox, but that didn't help.

I've tried using the pvesm nfsscan command and it only lists the 'public' share.

I've experimented with creating a proxmox user named 'proxmox-storage' and given them proxmox permisssions to be an admin for Datastore and added the same user on my NAS and given them read-write permissions to the NAS share, but it hasn't helped.

I'm hoping someone can provide me with some steps to set this up correctly.

Proxmox Version: 7.4-14
NAS: QNAP NAS
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!