[SOLVED] SSH Host Verification Failed ( Datacenter Cluster )

Dec 25, 2021
I run a platform called Parrot CTFs which requires a pretty weird and advanced network configuration. This also means I can have a lot of weird issues that sometimes do not make sense. I have a node in my Proxmox Cluster that keeps giving me this error: ( I blurred out the IP Addresses and Hashes for the sake of security )


I can also not access the VMs in the cluster when this happens:


I have followed quite a bit of advice on forums for this ssh issue, I ran the command it told me to, and the files are, in fact, updated. I even rebooted the machine after the fact. No change. I can access the terminal and VMS when logging in to the server outside of the cluster. There are also no issues with any other clustered server.

EDIT: I was able to solve this issue by detaching this node following this article: Remove A Node. There was some more I had to do to get the other nodes to stop showing up but ultimately, I just removed the node from the cluster and added it back and it was all fixed.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!